Welcome to the Global ROG Forum!

Discuss and discover the best ways to make the most out of your ROG gear.

Showing results for 
Search instead for 
Did you mean: 

Community Activity

Zephyrus GM501GS Battery Drain After Shutdown

Hi,My Zephyrus M is having battery drain issue after a complete shutdown (fast boot turned off). It drains about 4% in 24hours. I have not encountered this issue on other laptops before...Anyone facing the same problem?? How can i solve this issue??

anphi by Level 7
  • 10 replies
  • 0 kudos

AiMesh Wrong 5ghz repeated

I am running an aimesh system 3x gt-ax11000, and 1x rt-ac3100, all running ethernet as the backhaul.Every firmware since Version, has caused me headaches, all newer firmware cause the rt-ac3100 to repeat my 5ghz network that I have ...

TUF Gaming F15 Notebooks

Asus, in a big leap forward, has revealed its newest TUF Gaming F15 line of notebooks, interestingly produced in Brazil. This significant move has been influenced by the surge in the local market coupled with the booming eSports industry.Featuring mo...

Terrible sound quality with bluetooth

Hello. Just built a new system with Z690-Plus tuf gaming w/wifi and DDR4. Bluetooth works ok but sound quality is extremely poor. Tried a pair of beats studio wireless and a pair of airpods. Both sound the same over bluetooth. Tried youtube vide...

ROG RTX 4070 Ti led

Hello,I've got the ROG Strix RTX 4070 Ti OC and when I shutdown my computer a red led lights up :This led is off when the computer is on, and absolutely no problems with the card. I've setup the ERP in S4+S5 because the pump of the OC stayed up when ...

Snqk3 by Level 9
  • 9 replies
  • 2 kudos

G733PY-XS96 request

Asus,Could we get some love on AMD side of the house. Could we get some more useful options in the bios, or armory crate. Some voltage tweaking, or maybe some ram tweaks? Not sure why Intel gets all the love. Is there a DDR5 5200 list of compatibilit...

TechSef by Level 1
  • 0 replies
  • 0 kudos

Armoury Crate v5.6.3.0 Issues

There is already another post about this, but for extra attention I will make my own as well. FanXpert can not be updated in the v5.6.3.0, which results in being unable to control our fans. It comes with the following error: "Sorry, we cannot finish ...

Mardorr by Level 9
  • 16 replies
  • 18 kudos
Need Help?

For any general or technical support: Please go to ROG Care or Software

For any forum questions, you may contact: MasterC, Silent_Scone, Nate152, xeromist, world.

Welcome to the New Global ROG Forum!

Discuss and discover the best ways to make the most out of your ROG gear.

Top Kudoed Authors