cancel
Showing results for 
Search instead for 
Did you mean: 

Can't load "ROG Strix Scope II 96 Wireless" device page in Armoury Crate

schleicher_
Level 8

Hello. I recently bought the ROG Strix Scope II 96 Wireless keyboard. Armoury Crate got some problems for that keyboard. When I connected via 2.4 GHz option or via cable, I can not be able to see device page for my keyboard. It says some problem happened and the program will be reload that page but nothing happens. Same issue also happens for newer devices like mine, I mean for gaming mouse etc. also. For example, for the ROG Azoth, a newer update got the problem solved. I also completely uninstalled and installed Armoury Crate with tools from ASUS website, same issue is still ongoing unfortunately. I hope there is a solution for that or maybe an update on its way to solve that. It's annoying because I can not see any keyboard keys from there, not be able to use any macros or any custom settings, too.

 

armoury-crate-2.png

683 Views
1 ACCEPTED SOLUTION

Accepted Solutions

Nate152
Moderator

Very good, I see your keyboard and wireless dongle are up to date.

I can't say with 100% certainty, but I would think since they're updated, they should stay updated unless you do a hard reset.

So, I will say to uninstall Armoury Crate Gear, reboot your pc and install Armoury Crate version 3.2.11.2.

After installing, check your keyboard and dongle versions.

Armoury Crate - Support (asus.com)

 

 

 

View solution in original post

20 REPLIES 20

Aureliannn_ROG
Customer Service Agent

Hi @schleicher_ ,

to address your issue, we need to gather further details to better assist you in resolving the problem.

Firstly, when did this issue start occurring? Have you made any updates or changes to settings or software during this time?

Secondly, we recommend using the Armoury Crate uninstall tool provided on the official website to uninstall the software and then reinstall it. Also, please ensure that your keyboard firmware is up to date.

https://dlcdnets.asus.com/pub/ASUS/mb/14Utilities/Armoury_Crate_Uninstall_Tool.zip?model=ROG%20Strix...

You can also try connecting the keyboard to another device to see if the problem persists. 

This will help us determine if the issue is related to a specific device or the keyboard itself.

Additionally, does the issue only occur in 2.4G and wired modes? In Bluetooth mode, does the device appear correctly in Armoury Crate?

If you have already reinstalled Armoury Crate, ensured that the keyboard firmware is up to date, and confirmed cross-testing with other devices, and the issue still persists, please provide screenshots of the Armoury Crate update center page and logs for our reference.

Lastly, please ensure that the logs accurately record the situation when the issue occurs. 

You can follow the steps provided here to perform log operations:

https://www.asus.com/support/FAQ/1043747/#a14

After recording the logs, please upload them to the cloud and approve access, then send us the link via private messege.

Additionally, please provide the product serial number for further assistance. 

Thank you for your cooperation and understanding.

As I said, I just bought the keyboard like 1 week ago and the problem occured straight out from the box. I just uninstalled Armoury Crate with the uninstaller tool and reinstalled it even before first connection for my keyboard. After that, I installed every possible update for the keyboard from update center inside Armoury Crate. I accessed another PC and same issues happened there also with the latest updates for the Armoury Crate as well as device firmware updates, but I assume that this problem occurs also for other newer ASUS peripherals, too. For the 2.4 GHz connection question, I can not be able to see device when I connect the keyboard via cable, but in devices section, the keyboard and the other devices except omni reciever just keep disappearing and reappearing there. I mean, it was like you connect/disconnect a cable. After a certain time like ~10 mins, I can be able to click and see keyboard's specs and keys etc. if I'm lucky. Moreover, when we come to the 2.4 GHz connection, I can see the keyboard from devices, but when I click it I got the same error as in above screenshot from my first post. So, we can say that it's seems 25% problem for cabled connection and also 100% for 2.4 GHz connection. I'm also contact through private message for the logs and serial number.

Nate152
Moderator

Hello,

I'd like to jump in here with a reply.

I get this error too, but it can be avoided.

When you have the wireless switch on the keyboard set to 2.4GHz wireless mode, disconnect the cable. This should get rid of the page error.

When in wired mode, be sure to set the wireless switch on the keyboard to wired mode, this should get rid of the error.

Wait for the spinning red circle to stop, it may go to your motherboard page, then click your ROG Strix Scope II 96 Wireless in the Device list.

page error.png

2.4GHz wireless mode

2.4GHz wireless mode.png

Wired mode

wired mode.png

 

schleicher_
Level 8

I tried what you said, no luck. The actual problem is, in device list, everything (I got TUF B550M-E Wi-Fi Mobo, TUF RTX 3080, ROG Strix Scope II 96 Wireless and the Omni Receiver as all devices in the list),  just disappears and re-appears again like every ~20-30 secs. I'm adding screenshots for that error also (I captured a video, but don't have permission for upload). If I don't connect the omni reciever, disappearing and appearing devices from list problem is gone. So, I think the problem maker is the Omni Receiver itself. For the keyboard, still got the same error as before by the way if I can click before it disappears from the devices list...

armoury-no-devices.pngarmoury-crate-devices-2.png

Nate152
Moderator

Thank you

Try connecting the wireless receiver to another usb port, connect it to a motherboard usb port or one of your pc case usb ports. 

 

Dear @Nate152 , I'm currently using one of the ports on the motherboard and also tried all 5 other ports on the motherboard, too. Still same issue for all the ports. I'm also adding a video below for that issue.

https://drive.google.com/file/d/1Jm6i77sG3PRD1QiEek9S20tyZWH_jk75/view?usp=drive_link

I uninstalled and installed Armoury Crate after a BIOS update today. Still same issues, but now I can see the armoury crate warns me about an update for the keyboard and when I hit "Install Now" button, it redirects me to the update center of the app and nothing is there, it's just empty, I can't be able to update. As far as I researched, the firmware version of the keyboard is 5.00.02 currently, mine is showing 4.00.07. Maybe, I hope so, if can install that one firmware update, problem for 2.4 GHz connection (not showing the device page and all devices disappearing/reappearing problem) will be solved. I don't know yet, just waiting for an update to appear in the update center.

armoury-crate-update1-.pngarmoury-crate-update2-.pngarmoury-crate-devices-3.png

Nate152
Moderator

It seems you do need an update and I don't see any at the ASUS Support Center. So, this has to be done through Armoury Crate.

Try this.

1) Connect the cable to your ROG Strix Scope II 96 wireless keyboard and a pc usb port.

2) Set the wireless switch to wired mode (switch set to the center position).

3) Connect the wireless dongle to a pc usb port.

4) Try checking for updates in Armoury Crate.

These are my versions.

scope II 96 wireless updated.png

scope II 96 wireless update center.png

 

 

I'm also saying it to myself, because I saw many people like you got newer versions for the keyboard. Mine is 4.00.07 and for the dongle is 3.00.07. I applied every step you given me in the last post (I did that before by the way), but no luck. No updates in the update center, I hit check for updates button maybe 100 times, reset my internet, applied some public DNS also (I think that maybe trying to update from Türkiye is problematic with servers of ASUS, don't know), nothing happened. Still no updates. Is there any way to change where this armoury crate look for updates, I mean as a server maybe, by changing a txt file maybe to force the program look any other asus server to get updates from there or maybe with some certain DNS to reach newer updates. My versions are pretty old as numbers if I compare them with yours (and also can not be able to see dongle in the keyboard's device page like in your screenshot and it seems the keyboard treated the Omni Receiver like a normal 2.4 GHz receiver, not a special one, maybe this old version causes this, too).

omni-receiver-firmware.pngscope-II-96-firmware.pngupdate-center.png