cancel
Showing results for 
Search instead for 
Did you mean: 

PG35VQ red ghosting/offset after firmware update?

Mangonz
Level 9
I had a small amount of the known flicker on my month old PG35VQ when gaming and the serial number was in the range for the firmware update fix, so I went ahead and installed it last week...

It took about an hour to install and gave me the error 'Unable to normalise settings' when it hit 100%. There was a lot of flickering and interlacing visible in Windows afterwards so I just left it going for a while and then shut the computer/monitor down before powering up which seemed to fix it.

Anyway I noticed it looked a bit washed out from it's normal appearance afterwards so factory reset it and calibrated it (before the update calibration was fine out of the box) and colours/contrast are now back to normal. The issue now is that there seems to be ghosting/offset when displaying red that makes images seem blurry, for example the red text on a green background at the top of this page is smudgy.

I tried to take a picture of the ghosting on a red/white image with my mobile but it comes out grainy and is hard to see on top of compression. It's much more obvious in person so I'll describe it as well:
- The 'O' in Our has a still kind of visible ghosted half 'O' image in the middle of it
- The blue highlighted text has a shadow in front of it
- The little antenna symbol has a bunch of ghosting/noise
- Black on white and white on blue text is still crisp

84895


Has anyone else had this? I tried to install the update again, but I just get the message 'This update is not applicable for the current monitor' which I think means the firmware is now current and the previous update attempt was successful?

Thanks for any help!
1,888 Views
1 REPLY 1

Mangonz
Level 9
...And today it miraculously fixed itself.