cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to update firmware version from 101 to 103 - PG32UCDM

Moderator
Level 7

Hi,

I've tried to update the monitor from firmware 101 to 102 in the past with same results - monitor starts updating but then becomes a black screen with the control panel in the back being unresponsive.

Facing the same issue again with firmware 103. 

Both times I have been able to hard reset the monitor by removing power cable, replugging with both buttons of the control panel held and then the screen would become responsive.

No USB ports have been occupied except for USB A to B as instructed in the manual for the update process.

Any help/tips/steps to consider before updating would be much appreciated as HDR presentation at 101 is not the best at the moment.

464 Views
5 REPLIES 5

Nate152
Moderator

Hello Moderator

Do you have a Displayport or HDMI cable connected as well?

Try pressing the power button, it's to the right of the control panel button behind the ROG logo, you can't feel it but it's there. 

It's behind the red dot which is number 4 in the picture.

power button.png

 

Hi

Thanks for the response.

Yes, the only cables attached are Displayport and the USB A to B connected to the computer. I've tried pressing multiple combinations of buttons to get the monitor to respond but to no success.

 

Dawn_11
Level 7

I am in the exact same position. 102 would always give me an error, 103 would “sometimes” start to update and then fail giving me a “update scaler firmware fail.” Then my screen would go black even though it’s still on. Only have the usb-b to a cable and DisplayPort plugged in. Would love to fix this. 

Nate152
Moderator

Here are some troubleshooting steps you can take.

[LCD Monitor] Troubleshooting - No display after turning monitor ON | Official Support | ASUS USA

If the troubleshooting steps didn't help, I came across some steps to roll back the firmware, you could give this a try.

1) Unplug the monitor power cable.

2) Press and hold buttons 2 and 4 together at the same time.

3) With the buttons held down, plug in the monitor power cable.

4) Keep the buttons held down, wait until the monitor lights up and the roll back is complete.

5) Try updating the firmware again.

power button.png

 

 

 

 

 

 

Swatted
Level 9

What I did to diagnose why my update process wouldn't even start was to extract the update .exe with 7zip and run it uncompressed, that way the logs already in the file structure can update and I was able to see it froze halfway through enumerating the USB root hubs on my system (of which there's a LOT). With that information I was able to complete the update by unplugging a good number of USB things prior to running it.
Hopefully you guys can find equally usefull info for your issue in a similar way.