cancel
Showing results for 
Search instead for 
Did you mean: 

Armoury Crate and Asus Tuf Gaming K7 Turkish Q keyboard problem

vaal_zinc
Level 7
I updated the Armoury Crate and the other stuff that comes up in the Update Center tab in the Armoury Crate and started having problems with my Asus Tuf Gaming K7 keyboard. (Turkish Q)

When I press the number keys above the letters they started to type random stuff like wrong numbers or letters. Here is the video of the problem I'm having: https://imgur.com/a/HFtAPS8 Sometimes some of them don't even type anything and backspace stops working completely and sometimes some of the keys starts lagging and type different stuff.

I'm working from home and my keyboard become unusable. I was using this keyboard for like 2 months without any problems.

This stuff started happening with the latest Armoury Crate update. Lighting on the keys change randomly to a different setting too. Even when I set them back to my preference, they change after a while or after a computer restart.

And one other thing: at windows power options, in the "performance power plan" my setting of "never" "put the computer to sleep" option keeps reverting back to 15 minutes and 30 minutes. I'm using a 3 months old Asus Zephyrus G14 as a desktop workstation and it is always connected to the wall outlet with it's original power brick. This wasn't happening before that update.

+ I turn off the "Anime Matrix" from Armoury Crate and it turns back on after a restart.

I tried the keyboard on a different PC (a PC without Armoury Crate installed) and problem continues. I guess something is wrong with the updated keyboard firmware?

I contacted Asus Support and got told to uninstall the Armoury Crate with it's uninstaller tool and reinstall it. I tried it and nothing has changed. The keyboard is still unusable. I can't even enter my Windows pin at the login screen. It really is frustrating. It has been 6 days.

Some other Turkish user with the same keyboard is having the same problem too.
https://old.reddit.com/r/ASUS/comments/sq5zhl/asus_tuf_gaming_k7_keyboard_armoury_crate_profile/

Admins or developers check my video and please acknowledge this keyboard problem and help us. At least let us know that it's being worked on and it will be fixed with a new patch or something.

Please resond and help us. Thanks.
607 Views
36 REPLIES 36

@MasterC@ROG, all the users who has problem with Turkish Keyboards or any ROG products here, they are all know that this is a discussion forum. Customer service is not working here (in Turkey i mean). So, the users try to find their own solution.


MasterC@ROG wrote:
Hey Guys,

Thanks for making us aware but please remember this is a discussion forum, not customer service.
Who is still having an issue with the Turkish layout?
Have you tried a factory reset? (Hold Fn+Esc for ~15 seconds until all keys flash)
Did you uninstall Armoury Crate with our tool? (must use this to remove)
Did you edit the registry? (DO NOT do this, something bad always happens)

We tried many things.

Factory reset, app update, clean windows installation. Anything you can think of.

We also wrote to support. Support does not share information about resolving the issue. They just say delete and reinstall the app.

We shot videos, we sent logs.

THE PROBLEM STILL CONTINUES

We can only use our keyboards in default mode by performing a factory reset.

The keyboard becomes unusable when we customize it.


MasterC@ROG wrote:
Hey Guys,

Thanks for making us aware but please remember this is a discussion forum, not customer service.
Who is still having an issue with the Turkish layout?
Have you tried a factory reset? (Hold Fn+Esc for ~15 seconds until all keys flash)
Did you uninstall Armoury Crate with our tool? (must use this to remove)
Did you edit the registry? (DO NOT do this, something bad always happens)

Same here!!!

PesimistzOmbie wrote:
We tried many things.

Factory reset, app update, clean windows installation. Anything you can think of.

We also wrote to support. Support does not share information about resolving the issue. They just say delete and reinstall the app.

We shot videos, we sent logs.

THE PROBLEM STILL CONTINUES

We can only use our keyboards in default mode by performing a factory reset.

The keyboard becomes unusable when we customize it.

No one cares, software trash

MasterC
Community Admin
Community Admin
Sound like a factory reset would resolve the issue for some, but at least 2 people are still having issues.

We have received some logs from users and a solution is under testing, an HTML update should be released soon. In the meantime, I'm not sure if it is a silly question but can you use a different system language temporarily?
_____________________________________________________________
FPS, Racing, and VR Gamer / Tech Enthusiast / ROG Admin

It isn't happening, the problem continues

Asus rog flare keyboard

Windows 11 - system lang TR

MasterC
Community Admin
Community Admin
It should be resolved for your Flare in the HTML v3.00.23 update. Please check that you have it.

squrss wrote:
It isn't happening, the problem continues

Asus rog flare keyboard

Windows 11 - system lang TR
_____________________________________________________________
FPS, Racing, and VR Gamer / Tech Enthusiast / ROG Admin

yes installed and problem not solved, example; L Shift not working. it needs to be set manually by default

MasterC
Community Admin
Community Admin
Please go to this thread and fill out a form (see original post), thanks.
https://rog.asus.com/forum/showthread.php?128618

squrss wrote:
yes installed and problem not solved, example; L Shift not working. it needs to be set manually by default
_____________________________________________________________
FPS, Racing, and VR Gamer / Tech Enthusiast / ROG Admin

This problem was start " Device SDK version: 2.01.28 Date: 2022/02/10 and this update is last update.