cancel
Showing results for 
Search instead for 
Did you mean: 

Armoury Crate and Asus Tuf Gaming K7 Turkish Q keyboard problem

vaal_zinc
Level 7
I updated the Armoury Crate and the other stuff that comes up in the Update Center tab in the Armoury Crate and started having problems with my Asus Tuf Gaming K7 keyboard. (Turkish Q)

When I press the number keys above the letters they started to type random stuff like wrong numbers or letters. Here is the video of the problem I'm having: https://imgur.com/a/HFtAPS8 Sometimes some of them don't even type anything and backspace stops working completely and sometimes some of the keys starts lagging and type different stuff.

I'm working from home and my keyboard become unusable. I was using this keyboard for like 2 months without any problems.

This stuff started happening with the latest Armoury Crate update. Lighting on the keys change randomly to a different setting too. Even when I set them back to my preference, they change after a while or after a computer restart.

And one other thing: at windows power options, in the "performance power plan" my setting of "never" "put the computer to sleep" option keeps reverting back to 15 minutes and 30 minutes. I'm using a 3 months old Asus Zephyrus G14 as a desktop workstation and it is always connected to the wall outlet with it's original power brick. This wasn't happening before that update.

+ I turn off the "Anime Matrix" from Armoury Crate and it turns back on after a restart.

I tried the keyboard on a different PC (a PC without Armoury Crate installed) and problem continues. I guess something is wrong with the updated keyboard firmware?

I contacted Asus Support and got told to uninstall the Armoury Crate with it's uninstaller tool and reinstall it. I tried it and nothing has changed. The keyboard is still unusable. I can't even enter my Windows pin at the login screen. It really is frustrating. It has been 6 days.

Some other Turkish user with the same keyboard is having the same problem too.
https://old.reddit.com/r/ASUS/comments/sq5zhl/asus_tuf_gaming_k7_keyboard_armoury_crate_profile/

Admins or developers check my video and please acknowledge this keyboard problem and help us. At least let us know that it's being worked on and it will be fixed with a new patch or something.

Please resond and help us. Thanks.
8,551 Views
36 REPLIES 36

adeniz wrote:
This problem was start " Device SDK version: 2.01.28 Date: 2022/02/10 and this update is last update.


+
problem not resolved

last update is worse, very more mistakes

squrss wrote:
+
problem not resolved


Biliyorum, sorunun bu guncellemeyle basladigini ve bu guncellemenin hala son guncelleme oldugunu anlatmak istedim.

MasterC@ROG wrote:
Please go to this thread and fill out a form (see original post), thanks.
https://rog.asus.com/forum/showthread.php?128618


unfortunately still not resolved

xeromist
Moderator
If you have not made a report since the latest release please do so in the thread linked by MasterC.
A bus station is where a bus stops. A train station is where a train stops. On my desk, I have a work station…

xeromist wrote:
If you have not made a report since the latest release please do so in the thread linked by MasterC.


available

Problem is solved. After the upgrade divace SDK 3.00.02 13/06/2022