cancel
Showing results for 
Search instead for 
Did you mean: 

ASUS ROG Strix G G531GT-AL017T Stripes on Screen

nam1022002
Level 7
This problem occurred a while ago for me. I opened my laptop and realized there are horizontal flickering lines on the below area of my screen. There were some of them at first, and they just flickered for a while then disappeared. Then they started to appear more and more, and become permanent white or black stripes covering around 3 cm in that area. They appeared with the ROG logo so I thought it was a hardware problem. I was about to give up and go change the screen but then this happened: I always plug the charger on my laptop and put it in "Maximum lifespan mode" for the Battery Health Charging, that day I just unplugged it accidentally, my laptop turned into "On Battery" mode and then all the stripes disappeared, then I plugged my charger again and the stripes didn't come back. Since then, I have been doing that but it's still inconvenient so I want to ask if everyone has faced this problem or has any ideas on what this can be?

ASUS ROG Strix G G531GT-AL017T
CPU: Intel(R) Core(TM) i7-9750H CPU @ 2.60GHz 2.59 GHz
RAM: Originally 8 GB but I upgraded it to 16 GB right when I bought it.
Windows 10 21H1 64-bit
Card Driver: Intel(R) UHD Graphics 630 & NVIDIA GeForce GTX 1650
My warranty expired 3 months ago which is why I haven't come to any ASUS Authorized Service Centers.

I would love to hear any advice, if you need more information, ask me in the comment cause I'm not a professor in this field so I don't know if what I provide is enough or not.
3,824 Views
8 REPLIES 8

xeromist
Moderator
Does adjusting the brightness have any impact? Changing the power mode may have changed the brightness. It sounds like a hardware issue but maybe there is a way to minimize the inconvenience.
A bus station is where a bus stops. A train station is where a train stops. On my desk, I have a work station…

xeromist wrote:
Does adjusting the brightness have any impact? Changing the power mode may have changed the brightness. It sounds like a hardware issue but maybe there is a way to minimize the inconvenience.


Sadly it doesn't, even changing the GameVisual in Amoury Crate doesn't make any difference.

STARRAIN_ROG
Customer Service Agent
Hi nam1022002,
May I double confirm if you unplugged and plugged the ac adapter again and the stripes didn't come back at first, but after using for a while, the stripes would come back?
May I have the bios version and a photo about the stripes?
Thank you.

STARRAIN@ROG wrote:
Hi nam1022002,
May I double confirm if you unplugged and plugged the ac adapter again and the stripes didn't come back at first, but after using for a while, the stripes would come back?
May I have the bios version and a photo about the stripes?
Thank you.


Thanks for helping!
No, after plugging the adapter, the stripes won't come back at all until I shut down my laptop. Then, when I start it, the stripes will appear again and then I will have to do the trick again ^^
My BIOS Version: G531GT.308
Photo: https://blogger.googleusercontent.com/img/a/AVvXsEicVCE_YBMbQpVC09C0OPF6_0kkBNYVVt55NbKIn1bJTIF91HuK...

STARRAIN_ROG
Customer Service Agent
Hi nam1022002,
Do you connect the ac adapter after shut down and start the laptop, and the stripes appear again? or also appear in battery mode?
Do you have an external monitor? If yes, please connect an external monitor and then check if there are the stripes on an eternal monitor.
Thank you.

STARRAIN@ROG wrote:
Hi nam1022002,
Do you connect the ac adapter after shut down and start the laptop, and the stripes appear again? or also appear in battery mode?
Do you have an external monitor? If yes, please connect an external monitor and then check if there are the stripes on an eternal monitor.
Thank you.


Let me explain my routine in detail: A new day begins, I open my laptop with the ac adapter connecting, the stripes appear, I unplug it, the stripes disappear, then I plug it in cause I use my laptop all day. At the end of the day, I shut down my laptop with the ac adapter connecting and the next day it will repeat like that.
The stripes appear when I first open my laptop with the ac adapter connecting.
Disappear when I unplug it.

I will try to see if the stripes appear if I open my laptop without the ac adapter.
For the external monitor, I only have TV screens, so I will try to see if I can use them 😉

Stripes at 120hz, flickering @ 45hz

STARRAIN_ROG
Customer Service Agent
Hi aleck.designs,
Do you also use G531GT with BIOS 308?
Do the stripes and flickering occur in battery mode or AC adapter plugged in? also occur in bios configuration or with ROG logo?
Do you have an external monitor? If yes, please connect to an external monitor and then check if there are the stripes or flickering on an eternal monitor.
May I have a video about the issues?
Thank you.