cancel
Showing results for 
Search instead for 
Did you mean: 

Rampage IV Formula refuses to post

bturkyilmaz
Level 7
Hello all,

I was surfing the web on my PC the other day as the screen turned completely black and the computer reset itself. After that it has been refusing to boot. All fans turn on except my graphics card, but its light comes on and the problem replicates itself without a graphics card as well, so I am pretty sure it is not causing the issue. The red CPU led on the motherboard (Rampage IV Formula) for diagnostics comes up and does not go away, and the LED numbers which turn on with every POST stay off, so I think the problem lies within something pre-POST. I tried replacing RAM and reseating the CPU with no help. At this point I think the problem is within either the CPU or the motherboard but I cannot be sure. Any suggestions?

My specs are:
Intel Xeon E5-1650
Rampage IV Formula
2x8GB Crucial Ballistix Tactical
Sandisk Plus 240gb SSD
XFX RX480
Corsair 750W PSU

Thanks.
2,336 Views
3 REPLIES 3

FuryA
Level 8
hi
The Red light , it looks like Xeon E5-1650 problem, can you try install other CPUs e,g Core i7 series
or just rry update the BIOS / cleaning CMOS

Marcello_S
Level 7
A temporary overvoltage could have cause the issue. Builzoid raised the vCore of an Athlon up to 1.95 Volt and the PC suddenly shut down and refused to boot either post after that.

Well, I am unable to mount another CPU to my motherboard but I tried my own CPU with another motherboard, and it booted up fine, so I am thinking the problem is with the mobo. Tried clearing CMOS and the USB Flashback, it flashed the BIOS successfully but did not help. Any other suggestions?

Thanks in advance.