Showing results for 
Search instead for 
Did you mean: 

Z390-F BIOS updates (1902, 1903, 2004) all causing POST failures due to memory speed

Level 8
I've seen the other threads/posts explaining this issue, so this new thread is just to register that there is yet another user with the same issues.

Basically I've been on BIOS 1802 for nearly two years with 4x 8GB matched sticks of RAM and it has all been rock solid stable for that time. Parts are;

CPU: i5-9600k
Motherboard: ROG Strix Z390-F (currently on BIOS 1802)
RAM: 32GB (4x8GB) Team Group Vulcan T-Force 3000Mhz (16, 18 18, 38)

I upgraded to Windows 11 recently and checked for software updates for my Z390-F and saw that there had actually been a few in recent months, namely BIOS's 1902, 1903 and 2004. All of them claimed to add full Windows 11 support and Resize-BAR (yay!).

So I Load Optimized Default, flash BIOS 2004 with EZ Flash, then go about configuring up my BIOS settings. System won't POST.

I then flashed 1903, and then 1902. Same issue. I flash back to 1802, all fine.

After a bit of investigation it seems the BIOS from 1902 onwards don't like me setting my memory speed above 2400Mhz when using more than 2 RAM sticks. Using just two modules on BIOS 1902, 1903 and 2004 works fine at 3000Mhz, using four modules won't work on anything higher than 2400Mhz.

To summarise:

My RAM is 4 x 8GB DIMM. That's two matched sets of the same 2x8GB kit.

On BIOS 1902, 1903, 2004:

* Two modules (2x8GB) will work at rated speed.
* Four modules (4x8GB) will only work at 2400Mhz or under.

On BIOS 1802

* Four modules (4x8GB) will work at rated speed.

That's the issue. Any BIOS after 1802 will not POST with four RAM modules if frequency is set above 2400Mhz.

Every BIOS since 1902 has this problem.

lordoftears wrote:
In the end, I tried replacing my RAM kit with a fully compatible, one listed on the ASUS website (32Go, 2x16Go, DIMM DDR4 G.Skill RipJaws V PC4-25600 (3200 Mhz) (Nero), F4-3200C16D-32GVK ). Again, the same issue.

I also tried to export a txt file with the settings of bios 1902 and 2004, to compare them, but all the default settings are identical.

I suspect that behind some "auto" setting there is something different among the two bios that make my computer get stuck at POST.

So, I am still with 1902 bios.

I'm using a Z390 motherboard and I'm using 128GB Corsair Vengeance RGB Pro memory with no issues. The only issue I'm having is my 3080TI FE will not turn on the monitor until it's time to log-in to Windows. It does this only when restarting my PC. For this to happen during the restart, the monitor must shut off before the BIOS has had a chance to complete its posting.

Jesseinsf wrote:
I'm using a Z390 motherboard and I'm using 128GB Corsair Vengeance RGB Pro memory with no issues.

I performed every test and also disconnected all the hard drives. The only thing I should still check is the graphic card. I have an ASUS GTX 1660 Ti DUAL.

At the moment I have been able to install Windows 11 using a trick, without the TPM, but I think I will need a help of a computer shop to try different components and get deeper into this issue. Or just waiting for a new BIOS update.

Level 7
were u having issues before u installed new bios? cardinal rule..dont fix what aint broke

But it is broken: I need to install the new bios to run the TPM module.
At the moment it is impossible to do that, and ASUS is not fixing this issue that many people are reporting.