cancel
Showing results for 
Search instead for 
Did you mean: 

Z590-E: ASUS RTX4090 stuck in PCIE 3.0 mode

rozak1968
Level 7
Hello,

I installed my just arrived TUF-4090-GAMING-O24 *in my Rog Strix Z590-E PCIE4_1 slot and the card is stuck in PCIE 3.0 x16 mode.
I have i9-11900K with a Samsung 980 Pro installed in M2_1 slot. Drive reports running at PCIE 4.0 x4 mode.
No other PCIE cards installed. Only two NVME drives at M2_3 and M2_4.
Latest BIOS (1402) on board and latest drivers everywhere. Tested with GPU-Z, AIDA64 and HWinfo64. All report the same.

I have already performed a BIOS reset and loaded optimized defaults in BIOS. No change.

Resizable bar is on and reported as active.

OS is Windows 11 22H2, latest patches.

Otherwise the card seem to work fine.

Any idea anyone?
163 Views
81 REPLIES 81

Vasily_Nagornyk
Level 7
Maximus XIII Apex bios version 1601 - pcie 3.0! Bios version 1450 - pcie 4.0. LMAO what is happening..

Bimbominkia79
Level 7
It works! Thnak you very much

STARRAIN
Level 12
Hi orreonline and Bimbominkia79,
Thanks for letting us know it works.
We are dealing with this issue with NVIDIA. Please use the bios we provided during this period.
The issue is expected to be fixed in a future NVIDIA graphics driver.

STARRAIN@ROG wrote:
Hi orreonline and Bimbominkia79,
Thanks for letting us know it works.
We are dealing with this issue with NVIDIA. Please use the bios we provided during this period.
The issue is expected to be fixed in a future NVIDIA graphics driver.


I have a few questions: are we supposed to downgrade our bios (in my case from 1650 back to 1601) when the driver fix from nvidia is released? Will be 1650 bios officially released for TUF GAMING Z590-PLUS?

Killersjp
Level 7
My advice to people running a RTX 4090 on a Asus Z590 Motherboard would be to use the Beta 1450 bios if that works ok on your setup until either a release Bios with the fix for Pcie4 on RTX 4090 or Asus confirm a Nvidia Driver has fixed the issue. Hard to see how its a driver issue. if so why a beta Motherboard bios to fix, or i guess it could be fixed by a RTX 4090 bios update if Nvidia releases one.

STARRAIN
Level 12
Hi OVKrieg and Bimbominkia79,
For your questions, I will consult our tech team more about them.
Thank you.

Vasily_Nagornyk
Level 7
People, insist on beta 1450/1650 at support of Asus. Thats the only way to fix that bug. Last versions dont help with that issue. I wonder what do that new bios versions do, because I dont see any difference. At least cpu system agent stays stoud weak to get higher than 3733 at gear mode 1.

STARRAIN
Level 12
Hi OVKrieg and Bimbominkia79,
After checked with our tech team, for the PCIE 3.0 issue, please use the special bios we provided since formal bios doesn't include the workaround.
We are still dealing with this issue with NVIDIA. If NVIDIA releases graphics driver to fix the issue in the future, please update formal bios from our support site directly and then update the driver.
Thank you.

STARRAIN@ROG wrote:
Hi OVKrieg and Bimbominkia79,
After checked with our tech team, for the PCIE 3.0 issue, please use the special bios we provided since formal bios doesn't include the workaround.
We are still dealing with this issue with NVIDIA. If NVIDIA releases graphics driver to fix the issue in the future, please update formal bios from our support site directly and then update the driver.
Thank you.



Thanks, can you send me the special bios in pm please ?

I wanted to ask you another question in pm but i had this message : You have reached your stored private message quota and cannot send any further messages until space has been created.

STARRAIN
Level 12
Hi OVKrieg,
I've sent you pm. Please help to check it.
Thank you.