cancel
Showing results for 
Search instead for 
Did you mean: 

GX501Gl (i7-8750H) Model Aura Core DOES NOT WORK after clean Win10 install

halfbakers
Level 7
As the title says, I did clean install of Windows 10 on GX501Gl 8th gen Intel machine.

Product drivers page does not have Aura Core uploaded, and the Aura Core app found in Windows Store malfunctions, only thing I can do is all keys mode.
WASD mode and QWER mode all broken, does not work and turns all backlight off when I hit apply.

Also GX501Gl Aura Core that came with factory installed Aura Core can control ROG Logo light and Bottom vent LEDs, not found anywhere on Windows Store one
Doesn't really matter though since Windows Store Aura Core malfunctions anyway.

I suspect the one preloaded on system is the newer Aura Core pre-built for new 8th gen machine, problem is ASUS didn't upload this thing anywhere.
So I'm stuck with broken light control until ASUS decides to put upload the Aura Core specific for GX501Gl model. Anyone out there thinking about clean Windows install beware.
9,620 Views
27 REPLIES 27

ROG_HARDCORE
Level 7
You should have backup the esupport folder located in the c drive before any clean install.

You are missing the ROG GameVisual profile as well which will never get it back. If anyone else purchase the laptop may upload the esupport folder to help you.

Also share the experience using the GX501GI with us. We are screwed by asus by purchasing GX501VI. Let us know if they fix the bug on audio, etc etc.

ROG_HARDCORE wrote:
You should have backup the esupport folder located in the c drive before any clean install.

You are missing the ROG GameVisual profile as well which will never get it back. If anyone else purchase the laptop may upload the esupport folder to help you.

Also share the experience using the GX501GI with us. We are screwed by asus by purchasing GX501VI. Let us know if they fix the bug on audio, etc etc.


So the laptop breaks itself if you do clean install unlike any other laptop manufacturers ever?

Great, good on me for trying to clean install the Win10R4 update.

They really need to upload everything on the drivers page. Why does that page ever exist then?

ROG_HARDCORE wrote:
You should have backup the esupport folder located in the c drive before any clean install.

You are missing the ROG GameVisual profile as well which will never get it back. If anyone else purchase the laptop may upload the esupport folder to help you.

Also share the experience using the GX501GI with us. We are screwed by asus by purchasing GX501VI. Let us know if they fix the bug on audio, etc etc.



But I have to be honest to you. I am GM501 owner, I double checked my esupport folder in OS drive. It doesn't have AURA driver and gaming visual software preloaded. It only has gaming center and some ASUS software such as Live update, which are completely usless.

ROG_HARDCORE
Level 7
Not break, just doesn't work as new. Go to the shop, backup the esupport folder from the demo laptop. Ask for help from the retail shop.

Because asus dont give a fcuk. "Thanks for you 2899$ usd, now you can fcuk off."

ROG_HARDCORE wrote:
Not break, just doesn't work as new. Go to the shop, backup the esupport folder from the demo laptop. Ask for help from the retail shop.

Because asus dont give a fcuk. "Thanks for you 2899$ usd, now you can fcuk off."


Well guess I'm the stupid one here expecting ASUS laptops to work like any other laptop ever made out there. First ASUS gaming laptop, was not aware of this esupport BS. I don't think this particular model is in display anywhere, I guess I'll march into the service center and get my laptop reimaged with factory inage.

ROG_HARDCORE
Level 7
thats wierd. Can you upload to google drive and share with us.? Thanks:)

ROG_HARDCORE wrote:
thats wierd. Can you upload to google drive and share with us.? Thanks:)



Well, I have already removed everything. But we can see if somebody else can check their folder for more information.

federicosergio
Level 7
Same problem here, I had to make a fresh install after the infamous April 2018 update, and I forgot to back up the eSupport folder.
Hope Asus included a DVD instead of saving them on C:, but I guess we're in 2018.
On this page you can find driver and software for the last gen model, Aura Core seem to be working, but, if someone is willing to share, I'd really appreciate to have a copy of the original folder from a 2018 model owner.

Same problem here:
GM501GS + Clean windows 10 pro, the Aura won't work

Tried
AURA SYNC
https://www.asus.com/campaign/aura/us/download.html

And Aura core
https://www.microsoft.com/store/productId/9PG5Q8NSF0ZC

Can you have look at the comments of Aura core?

And I have checked the "esurpport" folder, there isn't AURA driver !