Showing results for 
Search instead for 
Did you mean: 

Wake on LAN not working from shutdown - Asus Deluxe Z170

Level 7
Hi guys
I hope someone here can help me as I cannot find any recent topic which covers this.

My problem is that since recently my PC wont boot from WOL when completely shutdown. If it's in standby then it will turn on from WOL packet but not when it is shutdown.
For this reason I believe my issue is NOT Windows related, as Windows the issue exists only when the PC is completely turned off.

It used to work fine, with Windows 10. I've not reinstalled the OS but I have installed all updates when released.

I read about the Fast Boot causing the problem for Windows 10. But even after disabling this and rebooting a few times it still doesn't boot from WOL...

When turned off I can see on my switch that the link is also down. Whereas when on standby I see the link is set to 10mbps so I know the NIC is off when the PC is shutdown.

This leads me to think it's a bios issue.

I found the EuP and PCIE Wake options. I experimented with different settings. Originally it was with EUP on (S4+S5 enabled) which from what I understand gives Windows the control to decide how to shut it down. I tried disabling that and setting PCIe wake enabled, but this hasn't resolved the issue.

I know it CAN work as I used it a lot last year when on holiday, always from shutdown. I know the WOL packet is good because it boots out of standby.

Please help! Why can't I get it to work from shutdown?


Level 7
WOL Fixed! For me was the Windows settings that fixed the type of shutdown somehow

Make screenshots
Update BIOS
Set settings how they were before update
Set Advanced\APM Configuration\ErP Ready = DISABLED
Set Advanced\APM Configuration\Power on by PCI-E = ENABLED

Open Powershell/CMD with ADMIN rights
Run: REG ADD "HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Power" /V HiberbootEnabled /T REG_dWORD /D 0 /F
Open device manager, find your NIC, open, drivers tab - Update driver. If nothing found, download directly from manufacturer website
Once updated, reboot.
After reboot, open NIC properties\Power Management tab:
Tick all boxes - Allow computer to turn off device, allow to wake up, only allow magic packet.
Open NIC properties\Advanced tab and (where available):
Set Enable PME = ENABLED
Set Energy Efficient Ethernet / Green etc = DISABLED
Wake on Magic Packet = ENABLED
Wake on Pattern Match = ENABLED
Reboot, then after reboot shutdown.

You should see the NIC stays enabled and you can boot from WOL packet. Bingo! Only took me 2 days.
For me the solution was updating the drivers and disabling energy efficient mode. Crazy

GemeenAapje wrote:


This worked!! Thank you

GemeenAapje wrote:
WOL Fixed! For me was the Windows settings that fixed the type of shutdown somehow

Man, we're almost in 2021 and you saved my life :cool:

Thanks a lot for this walkthrough, it worked perfectly with an Asus x570-e !

Thanks a lot, man!

Your solution also works on the Asus TUF Gaming Z490 Plus, with newest drivers and all the settings you wrote. Once I set them, it worked instantly.