cancel
Showing results for 
Search instead for 
Did you mean: 

GL702VM Won't POST

ReptillusMax
Level 7
My laptop ROG STRIX GL702VM won't POST. Screen is black, with no ROG logo splash screen. LED indicator light for battery (charging) and power works, but the storage LED doesn't blink even once. I tried removing battery and CMOS battery with no luck. Is there another way to reset BIOS CMOS?

I tried holding power button for 2 minutes again no luck. I tried removing both RAM modules and it gives flashing green LED indicator. Tried one of either RAM gives no flashing green LED, but still won't POST. I also tried swapping NVMe and HDD for boot drives and also Windows 10 bootable USB, but it doesn't look useful, since it won't even load the UEFI BIOS. The CPU fan is active, and all the USB ports output power, however the keyboard is off (Backlight is off and CapsLock does not toggle). I tried plugging external USB keyboard, but it isn't detected.

I'm out of ideas. I called Customer Service for repair cost, he quoted $600 USD. That's insane! If anyone ever solved this problem, please let me know.
6 REPLIES 6

FULLMETALJACKET
Level 7
How did it happened? Like all of the sudden or after an update, hardware change or something like that?

FULLMETALJACKET7 wrote:
How did it happened? Like all of the sudden or after an update, hardware change or something like that?


A BIOS change was made to set the boot order, which included turning off Safe Boot to enable for an older OS boot.

itswagi
Level 7
Did you ever find a solution to this because I have the same model and experience the same issues?

itswagi wrote:
Did you ever find a solution to this because I have the same model and experience the same issues?


I fixed the problem. It was unfortunately a damaged BIOS chip. For some reason I bricked the BIOS by changing the boot order, which is dumb. A friend charged me $40 to repair it instead of $600 though.