Showing results for 
Search instead for 
Did you mean: 

HELP!! Asus ROG MAXIMUS IMPACT VII PCIe Slot Not Allowing Dedicated AMD HD7850 GPU

Level 7
Motherboard model:


UEFI Version:

  • UEFI Version: 2601 x64
  • Build Date: 03/26/2015
  • Build Date: 03/26/2015
  • IROG1 Ver: RGE1-Z97-0132
  • IROG2 Ver: RGE2-Z97-0204
  • IROG3 Ver: MKEY-Z97-0138
  • ME VER:
  • PCH Ver: 00/A0


Intel® Core i7-4790K @ 4.00GHz

Memory kit part number(s)

G.Skill Trident-X F3-2400C10-8GTX

  • DIMM_A1 G.Skill 8192MB 1333MHz Trident-X F3-2400C10-8GTX DDR3
  • DIMM_B1 G.Skill 8192MB 1333MHz Trident-X F3-2400C10-8GTX DDR3

Memory kit amount in GB:

16GB (2X8GB) DDR3 Kit

XMP 1.3 Profile: YES

XMP 1.3 Profile #2 [O.C]


Intel® HD 4600 Graphics (On-board iGPU)

SSD/HDDs/Optical drives:

  • (P1) Samsung SSD 850 EVO Pro 250GB (250GB Samsung 850 EVO SATA3)
  • (P2) WDC WD30EFRX-68EUZN0 (3TB Western Digital Red SATA3)

No Optical


Cooler Master RS850-AFBAG1-UK V Series V850

USB Devices (model/version number):
Keyboard TEXET (USB2)
Wheel Mouse Optical USB and PS/2 Compatible 3892B535 (USB2)

BLUE-H H255 Digital (DVI)

CPU Cooler:
Coolermaster 120mm Seidon AND Corsair SP120 PWM X2 fans Push/Pull

Coolermaster Elite 130

Operating system: Microsoft Activated [yes]
Windows 8.1 Pro x64

Drivers Installed (include version):

The latest Official ASUS/Intel Drivers and the latest Windows Updates and Hotfixes for win8.1 x64 pro.
I will be happy to screenshot my Device manager or whatever to get this information in more detail.

Any third Party temp/voltage software installed:
CPUID ROG CPU-Z, Coretemp LatencyMon, AIDA64

System Overclocked (provide details)?
EZ Tuning (Gaming/Multimedia) > Water cooled >

CPU 4590 MHz
Ratio 45x
BCLK: 102.0 MHz
Temp: 34 deg.C.

Freq: 16384 MB (DDR3 2448MHz)

XMP 1.3 Profile #2


I am trying to get a discrete / dedicated GPU (AMD HD 7850) to work in the PCIe X16 slot.

Windows does detected it in the device manager under display devices as a windows simple device (Or something like that).

However, anytime I attempt to query the device under Device-manager or do anything to begin to install the HD7850 card the system halts.
Occasionally I catch a Q-Code 62 and loops

I have attempted to install the both the latest AMD Crimson AMD drivers and it hangs.
I Then tried the Catalyst v13.4 Drivers to install but it hangs again.
I have always loaded the Optimised Defaults whenever I make hardware changes like when taking the GPU card in/out.

It is either a bios setting I am missing OR could it be down to the card not being UEFI.

I have CPU graphics working fine at the moment HD 4600. But I would like to get both the CPU (iGPU) and the discrete GPU card working
OR most preferably the dedicated HD7850 GPU working and disable CPU Graphics.

Anyway I am at a loss and would appreciate anybodies help in solving this.

One final thing I have tried almost every possible combination of BIOS Settings to get this to work.
I have been trying to get this CPU/GPU to work since I initially purchased this M/B..


Level 7
So.. Can anyone help? Please don't tell me nobody has a opinion regarding my pcie issue(s)

I'm sure somebody could comment on this post?

I mean its not rocket science is it ?
Its just a small mobo which has a few new bits and pieces in the form of M.2/BT/WiFi daughter card (or is that sister card) anyway expansion card 🙂

Im sure with all the experience and wealth of knowledge in this forum someone could be kind enough as to offer an opinion/advise

Maybe, If my name was Linus from tech-tips I would have had a direct call from ASUS Tech-support by now; unfortunately, i'm just a mere
mortal who needs a little help.

Level 7
DId you try another slot and see if the AMD HD 7850 still have same issue? DId you try another video card on PCI 16 slot to see if it works? I want to make sure it is not faulty video card.

Legolas wrote:
DId you try another slot and see if the AMD HD 7850 still have same issue? DId you try another video card on PCI 16 slot to see if it works? I want to make sure it is not faulty video card.

Thanks for the reply Legolas.

This motherboard (ASUS ROG MAXIMUS IMPACT VII) only has one PCIe slot as its a very small form factor (like really small)..
Anyway, I can confirm that this GPU does work on my other machine which is a Gigabyte GA-990FXA-UD7 motherboard running an AMD FX 8350 CPU.

I have tested a R9 290X on this ROG motherboard and I have the same issue as described in the OP whilst trying the HD7850

So another words I have tested both GPU's cards Both working fine in other machines..
I cannot test my GPU in any other pcie slots as my (ROG IMPACT VII) mobo only has one pcie slot X16.

The only difference between the HD7850 and the R9 290X which I can find which could be something (or nothing) is the fact that the Box the GPU came in actually states UEFI support
I have conflicting reports on how to actually check the HD7850 for UEFI support but I believe that the HD7850 is NOT UEFI compatible..
This could be a possible problem as my setup is UEFI and the HD7850 could break the startup chain. IDK though, its just a guess..


Yep, I have a great little PSU 850W and as its fully modular.
I have double, tripple checked the 6-pin for the HD7850 and another card was 2X8 pin and also replaced cables in case they were faulty.
FYI: The GPU's fans spin up on both test cards and on the R9 290X the lights come one and the fans spin up also.

I would RMA the motherboard for the slot being dead.
Asus ROG Crosshair VIII Hero Wi-Fi Gigabyte X570 Aorus Master, AMD 3900X, EVGA 360 aio, 32gb G.Skill Trident Z Neo, Samsung 970 Pro NVME 512gb, WD Black NVME 1 TB, Crucial MX500 2tb, Zotac GTX 1080 AMP!, EVGA Nu Audio, CM HAF 932