cancel
Showing results for 
Search instead for 
Did you mean: 

Frozen Time Clock in UEFI - The Fix

Raja
Level 13
Is your motherboard suffering from the malady of a frozen time clock in UEFI?

If so try the following:

1) Reflash the latest UEFI, using EZ Flash 2 or USB BIOS flashback.

2) When the system POSTs, enter UEFI. Once in UEFI power down the motherboard. Keep the PSU attached and "on". Only the motherboard is powered off and in "standby". You will see the MB standby lights on (boards with start buttons onboard will be lit). Standby does not mean the board is actually running, standby means the board has power, but you have not pressed the power button to turn it on. Make sure the board is off before you go to the next step in this list. You will know if it is off because if you leave it for 5 seconds it should not POST~BOOT - this means it is in standby.



3) Clear CMOS (Clear RTC) for 10 seconds. This will clear the Management Engine.

4) Power up the system, enter UEFI, set the clock and then save and exit.

5) Update MEI driver to Version 9.5.14.1724 in the OS.










6 )Carry on using the system as normal.

The above steps should fix the issue.

-Raja
424,113 Views
375 REPLIES 375

VoSTRIKEoV
Level 7
Thanks, Raja. It helped with Maximus VI Formula.

Raja
Level 13
Cool 🙂

WebMaximus
Level 8
I had this problem too and was able to fix it by following the advice given above clearing CMOS.

Unfortunately though I just noticed when saving/loading OC profiles inside UEFI the problem reappears so hopefully there is a more permanent fix in the works that will address this issue?

Raja
Level 13
I see. Were those profiles saved or loaded at the time the issue occurred, or does it happen regardless?

Might be worth typing out the process of saving and what was changed. Can you by chance recreate this by simply saving a "bone stock" profile with no overclock at a point where the time is NOT frozen?

WebMaximus
Level 8
I haven't touched UEFI for a couple of days and since I last cleared CMOS and everything has been fine during this time so to me it appears the problem came back after changing stuff inside UEFI and loading/saving OC profiles.

Will try to save a "bone stock" profile as you suggest and see what happens. I will do this by first loading "optimized default" or whatever the name is and then save this profile, did I understand you correctly?

Raja
Level 13
Do this:

1) Reflash UEFI, then reset CMOS with standby power.
2) Go into UEFI. Load optimized defaults and then save that profile.
3) reload that profile after power cycling the system and let me know if the frozen time clock issue re-appears.

I need some precision to be able to send this to HQ for replication - so want to know what is causing it on your side, or if it's simply due to the fact you had old saved profiles that you re-loaded causing the issue to appear again. Starting afresh will help clear up some of these variables (important to flash UEFI first in step one above and clear CMOS with standby power).

-Raja

Tried what you suggested but this time I had no problems with the clock and I tried both saving a optimized default profile and then load it and also tried loading one of my own profiles.

So...not sure at this time how I managed to have the clock freeze again last time.

Should it happen again I'll try to remember exactly what I did and will then report back here.

Raja
Level 13
Ok thanks...

Hello Raja,

I should add to this thread. I have the MVIF and flashed to the latest 0804 BIOS. The "frozen clock" bug remains on my system.

Any further update to fix the bug?

Michael Downs