cancel
Showing results for 
Search instead for 
Did you mean: 

Spatha mouse no longer working after firmware update

Spoony
Level 8

ok so i have had a Spatha mouse since 2019 had issues at the start with disconnections but stopped TILL yesterday.

the mouse did an update for its firmware and no longer works, doesnt turn on doesnt charge doesnt do anything at all.

i have a damaged hand so this mouse is 1 of few that work and do not give my hand problems when using it.

the place i bought it from will not accept a return as its past 2 years. your support online doesnt speak English in the nation i am currently living in which is Switzerland so getting support is not possible,

i have been through the forums and done everything everybody else has done to get there mouse working but nothing works for me.

this is not far that a working product is now broken as a result of your software and i want my item fixed so i can use it again.

what options do i have ? as buying a new mouse isnt an option at the moment as i dont have time or funds for that

 


746 Views
14 REPLIES 14

Nate152
Moderator

Hello Spoony

Grab the cable from the box and connect it to your mouse and pc, set the wireless switch to wired mode.

Does your ROG Spatha X work in wired mode?

You can try these firmware updates. Click "show all" in red, there is a mouse and wireless receiver firmware update.

ROG - Republic of Gamers|Global | For Those Who Dare (asus.com)

 

 

 

 

the mouse no longer functions at all since the firmware update. it wont connect to a console a mobile charger a laptop another PC nothing. the mouse is no longer detected by the Asus software of armory crate or the older ROG armory. it did the update and turned off and refuses to do anything.

the firmware caused it nothing else, it was working fine till it did that.

i chose this mouse as i have a damaged right hand and my small 2 fingers dont move, so using another mouse they rub on the table or mat, this mouse they sit nice on the side slope which is the main reason i chose it other than for gaming or work.

i would like to send it back and get it reset if its possible as its clean with all original boxing and items.


Nate152
Moderator

Ok, let's try resetting your ROG Spatha, I have the ROG Spatha X so resetting it should be similar.

Here's how I reset mine.

1) Connect the cable to a pc usb port, let it disconnected from the mouse, but have it nearby. 

2) Set the wireless switch on the bottom of the mouse to wired mode (with the mouse flipped over, push the switch upwards).

3) Press and hold down, left click, right click and scroll click for 5 seconds.

4) With the buttons held down, connect the cable and release the buttons.

5) You should see an update in Armoury Crate for your ROG Spatha after the reset.

Does this get your ROG Spatha working?

 

 

tried all that and its a Negative.

i was playing and using the mouse till i got the notification saying new firmware update. clicked it did everything it said and then it turned off but as i said refuses to blink a light nothing, even the firmware that installed the new application was all in chinese well i think it was that language which was odd as it was an auto update via the ROG Armory of which i had already had installed on the PC


Nate152
Moderator

Ok, so resetting it didn't get it to work.

I find it very odd that an update caused your mouse to completely stop working. Something else to try is uninstalling your ROG Spatha from Device Manager, then reboot and see if this brings it back to life.

Uninstall from Keyboards and Mice and other pointing devices, then reboot.

Does this get your ROG Spatha working?

Spatha X uninstall.png

 

 

the Spatha mouse doesnt show up at all to uninstall but i just did a clean windows install after trying all what you said and still nothing.


Nate152
Moderator

Thank you,

Does your ROG Spatha have power?

With the wireless charging dock connected to your pc, set the switch on your ROG Spatha to wireless mode. Place the ROG Spatha on the charging dock, does the led lighting on the charging dock and ROG Spatha light up?

You can also try wired mode to see if your ROG Spatha is getting power.

If it's not getting power,  try disconnecting the wireless dock and cable from your pc and reconnecting it.

 

 

 

 

it has ZERO power with anything after rebooting. doesnt dock with anything charge with anything, nothing what so ever, you plug it in the docking station light turns on and instant turns off. mouse does nothing. it wont charge with a new cable or phone charger via 3 laptops or 2 desktops.

the ROG armoury installed the firmware asked to reboot so i said yes PC turned on but mouse was a massive NOPE. i went out and bought a new Spatha X and that worked instantly zero issues even charges on the old docking station for the Gen 1 mouse, cables work with it, used the new cables to get the old mouse to work and NOPE.

 

the firmware turned the mouse off and its bricked the mouse so it wont turn back on. im not some random person who has no idea about PC tech or building a desktop, i by high end gear not standard stuff. been building with ROG stuff since the Asus Ares 1st card came out and then with the 295x2 cards 2 in total 4 gpu's. i spend money on good stuff. the mouse thats at fault is in perfect condition to look at and box but doesnt work after the update.

i didnt break the mouse the update did, i dont blame you and i thank you for the support as nobody on Asus tech on phone gets the issue or has a clue how to sort it and just says after 2 mins just buy a new 1


Smatteo
Level 8

Same here, my dock stopped working a few updates ago.. I thought a new update  would fix it but it didn't. My dock flashes red and doesn't respond, the mouse works wired, it lights up when placed on the dock when in wireless mode, but no communication mouse to pc when trying to go wireless. Dock blinks red the whole time. . I've tried every troubleshoot imagineable from cords, to trying different usbs, to trying different mice, to uninstalling the spatha dock boot in devicemanager and reinstalling, and even AC reinstall+device reinstall. This is 1000% an asus armory crate problem, it worked fine untill the spatha update finished. There's also zero support on this.. I can't contact support with an email like a normal person... I feel like they did this on purpose so they get less complaints. I can't fathom buying anymore ROG in the future..  I've been buying asus rog products for years.. but the support and software for this stuff is really in an abysmal state. This hurts me to write because I absolutely love the style of asus rog line and have been a fan-boy for years..  But between Asus's shoddy products, general state of support, and armory crate just being like it's always been.. I feel like I need to cut ties with asus. The products and services  listed above are included in the worst pc experiences I've ever experienced and I wish I wasn't thousands in the hole from this company.