Showing results for 
Search instead for 
Did you mean: 

MediaTek Wi-Fi 6 MT7921 Wireless LAN Card disconnects (SOLVED)

Level 8

hello my MediaTek Wi-Fi 6 MT7921 Wireless LAN Card disconnects every 11-12h also it has Lag Spikes, its only in  the game League of Legends in WOW it is working what should i do? i have newest drvier software from 2.2.23


EDIT: Solution:

Hello i finally found an solution for that problem.

1. Download this version of the Driver

2.Go in Device Manager - Networkadapters and select properties at Mediatek Card

3. change at advanced from 8.02.11ac to AX and its fixeD!


Level 7

im facing kinda the same issue. The card disconnects 5mins after booting. Another issue that im facing is that even when my laptop connects to the wifi either wireless of through lan, it shows connected but no internet, but im able to browse stuff on chrome, though the windows update or the store or epic games, nvidia geforce experience wont work and show no internet connection. Please help, i have already tried resetting the wifi, reinstalling driver etc. I need serious help.

u rapair this?

Hello there, if you still haven't found a solution for your problem. You can try this (Asus TUF gaming F15) working perfectly fine with me

P.S You should already have created a restore point previously :

So I have tried nearly every solution written out there from updating the driver, uninstalling it, rebooting and entering BIOS but it would only work for a few minutes and then disconnects and I would have to restart the laptop.

As a last resort I tried resetting my laptop from a restore point. You can try the following steps:

To enable System Restore on Windows 11, use these steps:

  1. Open Start.
  2. Search for Create a restore point and click the top result to open the System Properties page.
  3. Click System Restore..
  4. Click the Next button.
  5. Select the restore point to undo changes on Windows 11.


حليتى المشكلة ولا لسة؟
عشِان مش لاقى حل و بتتكرر

الحل اللي انا كاتباه فوق هو اللي حل المشكلة ومبقتش تتكرر تاني لان اللي فهمته ان المشكلة في تحديث معين هو اللي بيخلي كارت ال wifi يفصل فعشان ترجع زي قبل التحديث محتاج ترجع اللابتوب لاعدادت قبل التحديث من طريقة

Restore point 

في طريقة تانية سمعتها بس مجربتهاش وهي انك تجرب تعمل restart لكارت الوايفاي 

بس الطريقة اللي كتبتها فوق هي اللي نفعت معايا... جرب وقولي لو نفع معاك.

Level 7

Try turning off the computer, then unplug it, wait about 30 seconds, plug back and turn it on. Helped me when i had similar problem.

Tried this also, didn't help.

It works for only 2-3 mins, then goes back to normal disconnecting

Level 7

same problem