cancel
Showing results for 
Search instead for 
Did you mean: 

Thunderbolt stopped working after latest Motherboard BIOS update (2204)

raugam111
Level 9
Hello everyone.

I have an ASUS ROG Strix Z690-A Gaming WIFI D4 motherboard and an ASUS ThunderboltEX 4 connected to it on the last PCIe slot.

I am running Windows 11 and use this device for music production which is my work (I require thunderbolt for my studio).

My build had been working perfectly fine with thunderbolt when I had BIOS version 1304. I did however have a different issue at the time where my machine would not post if I set any XMP (I or II) on. I was working with the BIOS load defaults and had to work with my RAM at 2666MHz despite it having a capacity of 4000MHz.

I noticed I was very behind on the BIOS updates so I thought perhaps this XMP issue would be fixed if I did the update. I updated to the latest BIOS version 2204 and it fixed the XMP problem. However, thunderbolt functionality completely stopped - which is even worse because now I can't really work. And for the record, I updated Intel ME before updating the BIOS.

Under "Device Manager" I see "Thunderbolt(TM) Controller - 1137" has a yellow triangle on it and when I see it's properties it shows an error message saying "Windows has stopped this device because it has reported problems (Code 43)". Also, if I go to the Thunderbolt Control Center app and click on "About" it shows the correct application version but the "controller driver version" has a weird "N/A". No devices get recognized when connecting via thunderbolt. I can tell it is passing electricity since my CalDigit thunderbolt hub's led lights up when connected but Windows does not recognize the device and it does not work. No thunderbolt devices work with different cables and everything so the the issue is clearly related to whatever changed in thunderbolt when updating the BIOS.

97312

I tried looking for more info on the "Event Viewer" but all I see is an Error stating the device "had a problem starting" with problem status 0xC00000E5. Which after doing some research does not really help me pin down a solution.

97313

I tried uninstalling and reinstalling the thunderbolt drivers and thunderbolt control center, updated all other drivers, completed all Windows updates and optional updates, removed the ThunderboltEX from the PCIe slot and then placed it back in... but it made no difference. Finally, I found that ThunderboltEX 4 had a TB & PD firmware update I could try. I followed the instructions and when launching the Shell.efi from BIOS I got a weird message for "Thunderbolt Nvm" which says "No support update ,Please check Thunderbolt installed correctly and try again, or contact Asus customer service". For the "Cypress PD" part of the firmware update, it completed with no issues and is now version 129. I don't understand why it does not want to update the firmware of TB though and I don't understand what it means by "No support update".

97314

I wish I could easily just go back to BIOS 1304 so I can have thunderbolt back but I'm scared to try since after BIOS version 2004 there are notes stating that rolling back to earlier versions is not supported. My only hope right now is that rolling back to BIOS 2103 or 2004 will resolve this. I'll report on that here but I was hoping someone had any ideas on what I can do to fix this. I really can't reinstall a fresh Windows OS since that would delete all my studio settings, configurations, plugins, programs which took years of putting together.
52 REPLIES 52

Well, I turned on my PC and again I lost access to my Thunderbolt devices......again. It's inconsistent and looks like it comes and goes when it pleases. Meanwhile, I have the most up to date drivers and firmwares installed. I am stumped like all of you.

DezM
Level 8

So, after receiving a PM about downloading TB drivers from his page, I went and downloaded and installed them. Rebooted and my Thunderbolt connections are working again. Not sure what's going on because the version numbers are exactly the same. Intel's and MoKiChu's: https://rog-forum.asus.com/t5/intel-700-600-series/drivers-intel-thunderbolt/td-p/914542

Thunderbolt is now working. I'm hoping it remains this way and Asus/Intel gets it together and make things workable for you all.
I haven't rebooted yet and hope it continues to work.

Ya, I tried that, didn't do anything for me.

The wait for ASUS to do something about this issue continues. It's probably because my TBex4 card is stuck on old firmware (v24) with no way to rollback by BIOS enough to update it to the latest (v36). I will likely need a BIOS update or a custom bridge BIOS as previously mentioned in this thread.

Sorry to hear that. I am always leery of those expansible cards. Prefer it being built-in to the board for compatibility.

Hopefully Asus are reading these post and will address a resolution promptly.

I'm not sure they're going to fix it. This appears to be an intel issue with Thunderbolt 4. I was looking at forcing a downgrade on my system to the 2103 BIOS via UEFITool and when I went to download the older BIOS I saw this note that has been added to the 2204 BIOS for my board: 

"Thunderbolt 1/2 devices will no longer be supported by BIOS 2204 due to a change made by Intel regarding the update of Thunderbolt firmware to NVM 36".  So this BS is caused by Intel just breaking compatibility for...reasons? Screenshot 2023-04-06 16.03.30.png

What are those of us with perfectly good hardware that is only Thunderbolt 2 supposed to do about this? New motherboards will only be TB4 going forward, but equipment manufacturers are still making the TB2 gear. My MOTU 828ES is only 15 months old! I bought it in Jan 2022 at the same time I got the Z690I and everything else,  and it cost almost as much as all the other components in my PC combined ($1k). Now it's useless for the specific purpose it was purchased (and used for a year) for because intel is too lazy to maintain their firmware codebase? I have a hard time believing this is really what's going on.

If anything, ASUS needs to provide a path for us to rollback to whatever version came before NVM 36. 

I tried all the suggestions here from everyone, which I truly appreciate you all taking the time to come here and post on this thread to help each other out on our issue. I have ThunderboltEx4 stuck on old v24 firmware as well and I believe that is the culprit of all this. I tried updating the firmware of my thunderbolt card but the BIOS no longer allows me to, so we are stuck with this incompatible firmware version. Only a motherboard BIOS update that fixes this or a custom bridge version will allow us to rollback to be able to update our firmware.

However, ASUS support so far said they cannot reproduce the issue and they are asking us to send our motherboards and thunderbolt cards in for "repairs". 

raugam111
Level 9

I really hope ASUS gets back to us here and provides us all with a solution. In the meantime, I have been trying to request this customized bridge BIOS but ASUS support says they are not able to replicate our issue and I am not sure if they are even working on customized bridge for us. I hope we can get some answers here from a representative.

Based on some conversations I've had here and other places, I'd be contented with the ability to roll back to whatever BIOS has NVM firmware prior to v36. That's been the recommendation from everyone so far -- find a way to get to pre-36 NVM firmware. Unfortunately, my EZFlash won't let me roll back, even with the setting enabled in BIOS to allow it.  So my next step is to figure out how to make that happen, or bug anyone and everyone until they DM me a roll back bridge :).

scriv
Level 8

@Steavis @raugam111 @DezM @Jiaszzz_ROG 

UPDATE: Hey Everyone! After doing a deep dive into the TBex4 controller and my MB's BIOS I was able to get the ThunderboltEX 4 card working as it should. Keep in mind that my solution may not work for you and will depend entirely on your hardware.

IMPORTANT: Once you update the TBex4 hardware to NVM 36 there is no going back at this time. Meaning if you are running anything that uses TB1 or TB2, don't update the firmware! If you want to keep using TB1 & TB2 devices with the TBex4, then you're going to have to stay on an older BIOS version.

Motherboard: ASUS Z790-P-WIFI
DRAM: 128gb DDR5 5200mhz
Operating System: Windows 10 Pro 64Bit
Thunderbolt Controller: ThunderboltEX 4

MY SOLUTION:

1. disconnect all TB devices, uninstall TB drivers & TB controller software
2. download all available BIOS updates for your MB from ASUS and put them on the same USB stick. You're going to have to rollback version by version, it won't work if you skip a version, I have no idea why but I tried it failed each time saying the chosen file is not a valid BIOS file.
3. reboot into the BIOS (my latest version is 0812, if you're using a different MB, yours will be different)
4. roll back your BIOS to the next previous version (0809 in my case)
5. setup bios as required for TBex4 operation & disable fastboot. Here's a YouTube video of the settings someone made that I used and that worked for me as well: https://www.youtube.com/watch?v=_mFAx1VzwZ8
6. save & reboot into bios and attempt TBex4 update.
7. repeat steps 4-6 until you get to the BIOS version that allows you to do the update. (In my case it was version 0602, from September of 2022)
8. Once the TBex4 Firmware is updated, proceed with updating your bios to the latest version. You may need to update version by version until you're at the most recent one.
9. Once at the latest BIOS Version, reboot into BIOS and make any other changes you want to make. Ex: XMP, boot configuration and such.
10. save & reboot into the OS
11. download and install a Thunderbolt Controller software & drivers from ASUS & reboot into OS
12. reconnect Thunderbolt device(s). You may have to reboot with them connected as well. You may also need to have a TB device connected when updating the drivers.

SIDE NOTE:
In my case I had to download & install the Thunderbolt Controller Software(v1.0.36.0) directly from Intel and then uninstall the drivers it came with it only to then install the ASUS drivers because ASUS's version of the Intel Thunderbolt Controller Software (v1.0.34.0) included in my MB's driver updates doesn't install properly and the newer Intel drivers wouldn't work with the TBex4 Card. There were 3 TB drivers that needed to be uninstalled. I just uninstalled the devices, scanned for hardware changes and then updated all of them with the ASUS drivers and rebooted. The 3 devices that needed drivers uninstalled and updated were as follows:
- Thunderbolt Controller 1137
- Thunderbolt HSA Component
- Thunderbolt Toast Component

Here's a screenshot of the final results:

Screenshot 2023-04-08 202308.png

 

 

 

 

 

 

 

 

 

EXTRA:
I also had issues with my WIFI and Bluetooth adapter disappearing despite all my drivers being up to date, or so I thought. According to ASUS they were all up to date but they were not! I recommend using Intel's Driver & Support Assistant to make sure all your Intel drivers are up to date. Fixed my adapter issue. ASUS is a little behind on their driver updates.

CONCLUSION:
As I stated, this solution may not work for you but so far it's working for me. I've rebooted multiple times without the issue coming back and haven't been able to make the TB connection fail.

ASUS, if you're reading this forum, may I make this following suggestions:

1. Work with Intel on your updates with respect to Thunderbolt. Providing firmware updates that break/reduce capabilities of a product is just plain asinine. Not to mention updating via a shell script, really? There's got to be a cleaner way to do that without going through the bios.

2. Don't push BIOS updates that prevent the updating of your own expansion hardware, actually test it first.

3. Publish the BIOS settings that are required to make your products work! The ThunderboltEX4 literature is severely lacking in this area.

4. FIX YOUR SH*T PROMPTLY!
My solution was/is an overcomplicated mess that most people who aren't tech-savvy would not even attempt on their own. You can not reasonably expect the general public to do what I have done and many people who build their own PC's wouldn't have taken all the steps I have to figure out a solution. Furthermore, my solution could break at anytime with a driver update. How am I suppose to even trust that your hardware will continue to function. As is obvious from posts throughout this forum and from those on Reddit that I submitted to your tech support, this is not an isolated case. This is a problem that plagues your ThunderboltEX4 cards across numerous different motherboards and has for the last number of weeks at the very least. Get on it and provide a rollback option or an update ASAP.

5. Tech support was suppose to contact me within 24/48 hrs with an update on my support ticket... it's been a week. Do better.

________________________

Lastly, @raugam111 sorry for hijacking your post, maybe my solution will help you, I don't know but regardless it's something to try if you can get your BIOS to revert to a previous versions ever.

To everyone: I'll be in touch if/when I ever hear back from ASUS' tech support.

Hi @scriv and thanks so much for sharing all this. I hope it can help any users here that have a similar situation. I really wanted to give this a try but then realized you weren't stuck in a 2004+ motherboard BIOS version. ASUS please help us so we can get back to use our builds and work. We shouldn't have to go through so much trouble after updating our products.