Showing results for 
Search instead for 
Did you mean: 

PC stuck in continuous reboot after bios update

Level 9

I have a PC that has been running great. Until a bios update on my Asus motherboard appears to have broken it. Specs below:

Ryzen 7 5800x3D, Asus ROG B550-F gaming wifi, Asus ROG RTX 4080, four 8gb Corsair Vengeance RAM sticks, Asus ROG LC II aio, Asus ROG Thor PSU, 3 coolermaster sickleflow fans.... Think that's all that matters. 

PC was running great for months, and I did a Bios update to the most recent version released on 2024/04/03, the PC starting rebooting continuously - for days when I could sit nearby it. I made it to windows for a maximum of about 6 seconds. Had just typed in my windows PIN before it would reboot again. After sitting next to the PC for a few hours, somehow I managed to get into windows without it crashing. I got the previous version of the bios I was on (Version 3002) onto a USB, and managed to get my bios rolled back. Once it was done installing, I was about to get into windows again, and did a system restore to a point I set before I upgraded to the newest version (3607). Finally, after 5 days I fixed it... Then it rebooted. And on again got stuck on a reboot loop. Restarting before I could get into windows.

But this time I was able to get past the Bios and get a Windows error, so I decided I would just try re-installing windows. Which it crashed and rebooted during 4 separate attempts to do so. On the fifth try I was able to fully re-install windows. But once again it is stuck in a reboot loop and won't get past the Bios loading screen.

I don't know what to do. Any help would be appreciated. 



Super Moderator

Hi @TwistytheGr8 

Firstly, make sure everything is at Optimised Defaults by clearing the CMOS. Are you enabling EXPO/XMP? If so, disable this and retest. EXPO/XMP is classed as overclocking, and removing any overclock is troubleshooting 101.

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

Yes, a few of the first things that I tried. Any other ideas?

Thanks for trying to help me out.

I am having the same problem. 

Running Windows 11 on a Asus Rog B550-F Gaming (Wifi) motherboard (AMD Ryzen 7 5700G). I was experiencing random freezing and reboots of Windows. I decided to update the bios. I followed the instructions, first updating it to  3607. It has been looping. It won't get to the windows login at all. It stops at the ROG screen. The dots or circle will freeze while circling. I tried rolling back the bios to 3202, and that didn't work either. 

After updating to 3202, I went into the boot screen in the bios, and I saw an option for a UEFI drive, but didn't select it. I left it on my M.2, which I believe is my main drive. (I also have a SATA drive. Neither the m.2 nor Sata are pulling up.) After my first boot, it froze again. I tried going into the bios again, and this time the UEFI drive wasn't there. 

All I know is that my PC was at least working before I updated the bios. Now I can't get past the ROG screen to Windows at all. 

Please help! 

I never solved it. After a call to Asus customer support, I was told that because my motherboard was no longer under warranty, I could send it in and pay for repairs. The only reason I pulled out this old PC was because a bios update did THE SAME EXACT THING to my Asus x670e Hero edition and bricked that too. I've never bought a motherboard in my 12 years of building PCs that wasn't an Asus... Been weighing my options. 

I tried Everything. Buying a new SSD and trying to start a new windows install after reverting the bios didn't even work. It would crash while attempting to install windows on a never before used SSD.

If you end up finding an answer some day, please find me wherever I am and tell me. Please. 

Right now, when I boot, the ROG splash screen gets a quick partial circle that moves a little bit. Then black. Then the ROG splash screen with the option to go to UEFI Bios. Then black. Then a ROG splash screen that says, "Preparing Automatic Repair." A circle begins again. It freezes. That's it. Everytime. 

My PC was working earlier tonight before I tried to update the BIOS. This is the problem I have even after rolling back the BIOS.  

Same exact problem with both of my afformentioned motherboards. Im not a computer genius by any means, but building PCs for as long as I have, I would like to think I know some things.

All I can recommend, is that in the future when updating your Bios, Google that specific bios version with just the word "problems" or "issues" after it, and maybe hold off on some updates. 

I will be praying for you the next couple days while you are seriously considering running over your whole PC with every car you see. 

I would also suggest buying a new motherboard from Amazon (because of the easy returns), swapping it out, and seeing if the problem persists. If you have no issues on the new one, sell the bricked one for parts on eBay, and maybe get $30 out of it.