Showing results for 
Search instead for 
Did you mean: 

Asus Tuf Gaming X670e RAM problem?

Level 7

Hi All, hopefully someone can help, and hope this is the right place to post.

I have an Asus Tuf Gaming X670e Plus WIFI motherboard, with a Ryzen 7700X and 32GB of RAM, I just purchased a new Ryzen 7800X3D to upgrade my rig, installed it, then powered on, the motherboard RGB lights cam on and nothing else, no fans no nothing, so i reinstalled the 7700X and powered on, everything lights up and I instantly get the QLED for DRAM light up then 1 long beep and 2 short beeps, which signify s a RAM issue? I've re-seated, tried 1 stick at a time, even changed channels, but it's the same result. I also put the 7800X3D back in, and this time it start with the same issue, system powers up with the QLED for DRAM lit up.

Question: Could the 7800X3D killed my RAM or could it have damaged the motherboard memory controller?

Thanks for any help given.


Level 7

An Update, Seems that DIMM slot 2A has died? got the new processor in with a stick in DIMM slot B2 and all seems like it working.

Is there anything in the BIOS that will help with this issue?

Super Moderator

Hi @malley_vinom 
I've moved the thread to ROG care for attention of customer service.

Did you inspect the CPU pin pad for any debris or bent pins? DIMM detection issues are quite often due to improper pin contact or socket damage.


13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

Hi, thank you 🙂

Yeah, think maybe a some debris there, not sure though, tried moving it with a pin and seems quiet firm. got a pic, if there's anyone that can confirm it's not supposed to be there, I'll remove it.

Customer Service Agent

Hello, @malley_vinom 

Thank you for reaching out to us.
Regarding the image you provided, may I ask if you are referring to the stain that looks like thermal paste?
Could you specify which part of the motherboard it is, or perhaps provide a more comprehensive image?

Concerning the Q-LED DRAM indicator on and the one long and two short beeps, they indicate a memory issue after boot.
Could you share the specifications and part number of the RAM you're currently using and confirm if it's listed on the TUF GAMING X670E-PLUS WIFI QVL?
Also, if you haven't updated to the latest BIOS version 2413, released on February 7, 2024, consider updating, clearing CMOS, and checking again.

Thank you.

Sorry I should have circled the issue, which looks like it could be a single pin bent right over, and I have no clue, as to how that has happened...

Yes, that is some thermal paste, CPU has been switched out a few times now. The RAM is "G-Skill Flare X5 DDR5 Memory Kit 32GB (2x16GB) 6000mhz" part num: F5-6000J3636F16GX2-FX5 and is listed in the Asus memory support list. and I'm using the latest BIOS version 2413, the CMOS has been cleared several times.

Thank you for your response.

Level 7

Sadly looks like there is no way to fix this issue, and the only way I can see this could have happened is when I lifted the 7700X out the pin had attached it's self to the bottom of the CPU raising it vertical and when I put the 7800X3D in it has pushed the pin all way over.

Seem that switching out a CPU on the am5 platform is a very risky thing to do.

Customer Service Agent

Hello, @malley_vinom 

I'm sorry to hear about the bent pins on your CPU.
Regardless of the number of bent pins, it could potentially lead to issues during booting or while the system is running.
We would recommend replacing it and checking again.

Thank you.

It is only 1 pin that is bent/damaged, and how is this possible without damaging the other pins around it, it's completely impossible! the only way that this can happen it that if the pin has become attached to the bottom of the CPU and when lifting it out has pulled the pin up and when seating the new CPU has pushed the pin over, There was no problem with switching the CPU over, I lifted the old CPU out and gently put the new one in, it wasn't dropped in, slid in and I didn't fumble it in anyway, this has left the MB with 3 of the memory slots not working

This can happen absolutely anyone that wants to upgrade their CPU on the AM5 platform, it's a design fault in the fact that just the act of upgrading your CPU can damage the socket.

I've had to shell out $380 for a new MB (the cheapest I can get here in Brazil) because of a single damaged pin, that isn't my fault.

I've attached a pic of the socket so you can see that there is no other damaged pins.

I have the same issue with DRAM led on mobo. Asus sent me a new mobo, and it’s doing the same thing. They said they would RMA it again