Showing results for 
Search instead for 
Did you mean: 

ROG Strix Flare II Animate - UK Layout Keys no longer working

Level 7
Wondering if anyone else with the UK layout keyboard has had the same issue? Have been chatting with support, but they don't have a solution and have said to return it.
The UK layout used to work, so am wondering if a recent firmware update might have changed something - other UK specific keys still work (e.g. £) but the ones highlighted have stopped working recently.
Though I'd try here before sending back.



Hi Nate152,

I've checked and everything is as it should be in the language settings (the laptop keyboard works as expected in UK layout).

I've also testing the keyboard on a Raspberry Pi using "showkey --scancodes" - every other key registers a response, but there is nothing coming from those two specific keys.


I've checked through all of those suggestions with no success.

I'm pretty sure the last keyboard firmware update through Armoury Crate is when it stopped working.
Is Crate the only option for update? Is there a UK firmware I can reapply to it?


Yep, ran through all of that with support - still no luck.

It's definitely something with the keyboard itself as I've tried it on multiple systems. Think I'll have to arrange a return.

Thanks for the help, though.

You can try resetting the ROG Strix Flare II Animate by pressing and holding the FN + ESC keys for 10-15 seconds.

Thanks - have given it a go, but it's still not rectified the isse.

Something else to try is uninstalling Armoury Crate with the uninstall tool and reinstalling.

In the link below, select your operating system and click "Show all" in blue, the Armoury Crate uninstall tool is the third download.

Once uninstalled, install Armoury Crate version

Does this get the two keys working again?