Showing results for 
Search instead for 
Did you mean: 

[FIRMWARE] Intel ME (H610/B660/H670/Z690/B760/H770/Z790)

Level 19

Hi everyone,

- Intel ME Consumer Firmware :

Firmware : [11/07/2023]
PMC Firmware : [14/11/2022]
PCHC Firmware : [06/07/2022]
PHY N Firmware : [21/06/2023]
PHY S Firmware : [30/01/2023]
Download : Link

Check/Update Process :

Check current version : Right click on "Check.cmd" > Run as administrator

Install/Update : Right click on "Install.cmd" > Run as administrator > Automatic restart when install is done

OS requirements : Windows 10 64 bit or more recent.
Hardware requirements : Motherboards with Intel H610/B660/H670/Z690/B760/H770/Z790 chipset.

207 REPLIES 207

That was the first thing I tried actually, but the issue persists. The only way I was able to update my ME firmware was by using WinPE and running it in there. Thanks for the suggestion anyways

Level 7

hi, Error 20: Cannot locate ME device(if use this files). ROG MAXIMUS Z790 HERO support page show only two versions of MEUpdateTool and

Level 7

thank you, but i found this in internet and installed them yet... is it possible i did something not right? i updated before by update tool from 2020 to 2124 and update tool worked before

Which Intel ME Firmware version do you see in these places :

Firmware tab in the Properties of your Intel MEI device : Device Manager > System devices > Intel(R) Management Engine Interface #1.
Main tab in your BIOS (Advanced Mode).

Level 7

i did what you said, so probably 3rd time, because i did it after install windows too... but Error 20: Cannot locate ME device.

only update tool didn't gave me any problems but there only old versions on site

looking a little odd2023-06-18_144358.jpg

btw... on the support page TEEDriverW10x64.sys file have latter date than you suggest me, i mean intel driver component mei\win10 etc.

Level 7

strange thing couple a month ago this parameter is gone... so i just don't see it at all(device manager)... in bios

If I asked you to check the Intel ME Firmware version displayed in both (in your Device Manager & in your BIOS), it is to determine if your Intel ME Firmware is corrupted or not. So since you can see your current Intel ME Firmware version displayed in your BIOS (, your Intel ME firmware is not corrupted (you would have seen as Intel ME Firmware version in your BIOS if your Intel ME Firmware was corrupted), so the root cause of your issue (Intel MEI Device missing from your Device Manager) seems to be located either at the boot side, or at the Windows side :

- Turn off your PC > Turn off your PSU for 60 sec > Turn on your PSU > Turn on your PC
- If your Intel MEI Device is still missing from your Device Manager : Please show me a full screenshot (or link me an .csv extract : File > Export) of all your DriverStore via Driver Store Explorer (to launch as admin). there file

and screen