Showing results for 
Search instead for 
Did you mean: 

Armoury Crate not recognizing devices and unable to control RGB

Level 7

Just upgraded to an AMD Ryzen 3700X on a Crosshair VIII WiFi mobo.

Yesterday RGB and armoury crate worked fine.

Had to update BIOS and some general drivers and Armoury crate no longer recognizes my motherboard (this sercice only works with ROG devices or something along those lines) and when I click the AURA button I get the message ''connect at least one aura sync compatible device'') which I have:

-Thermaltake fans and RGB strips on a Thermaltake Aura Sync hub which worked yesterday just fine

-EKWB velocity rgb waterblock
-Bitspower Aura sync compatible flow indicator

all of these are eiter stuck on red or rainbow unicorn barf.

What is causing this? Have already tried reinstalling, clearing CMOS, safe boot reinstall, CCleaner registry cleaner, manual deletion of remnants I could find, REVOuninstaller,.... nothing works.

Any ideas?

Have also tried installing only AURA SYNC but that doesnt even start saying that the auraservice is not running even though I followed all the guides I could find online for installing that program.

Why does none of this work??????

Ez felháborító hogy az Asus nem tesz semmit !!!

Évek óta asus termékeket használok!

Most váltottam rog termékekre szinte mindenem rog egy vagyon volt sok pénzbe került !!!

És a soft egy nagy szar !!!

Adják vissza a pénzem !

I have uninstalled and reinstalled software doesn't recognize motherboard. Have tried using guide that was posted but no effect. asus rog b450-f series processor is amd ryzen 7 2700x wraith cooler also doesn't respond to changes in amoury crate not sure what else to do.

It's been a couple of weeks since my LiveDash is not responsive. Actually, Armory Crate does not recognize the MOBO.

Icue used to be able to recognize it, but now it is also not displaying my Asus hardware.

I've reinstalled several times, cleaning registry each time, to no avail.

Is there any fix I have not tried?

It worked for me when I uninstalled Armoury Crate and then installed it back from below link

rog_ravver wrote:
It worked for me when I uninstalled Armoury Crate and then installed it back from below link

I downloaded from this link, but it simply doesn't work.