Showing results for 
Search instead for 
Did you mean: 

Need help with Armoury Crate and/or Asus Aura

Level 7
Good Evening,
Is there an easy way to remove ALL the Aura Sync and Armoury Crate components from my system and basically start over without doing a full wipe of my OS? I would prefer to get Armoury Crate up-and-running, but would even be satisfied if Aura would consistently run. I would try a full OS re-install, but from what I’ve read, that will not fix the problem.

I recently build a gaming PC. I have never been able to get Aura or Armoury Crate to work properly. I purchased most of the parts because they are supposed to be Aura compatible, but have had nothing but problems. I turned on my system again today, and found that once again, my lighting is messed up and not working properly, but I can’t get Armoury Crate or Aura to install. Aura sometimes installs, but then stops working after a few days. When I try to install Armoury Crate, after I approve the change in the User Account Control, a black System box flashes on the screen, but then nothing happens.

My system has the following components:
• ASUS ROG Strix B450-F Gaming motherboard
• AMD Ryzen 7 2700X processor w/Stock LED Fan
• EVGA GEFORCE RTX 2070 Super FTW3 Ultra Video Card
• 64gb (4x16 sticks) G.Skill Trident Z RGB DDR4-3000 RAM
• Seasonic Focus Gold 650 FX power supply
• Thermaltake Level 20 ARGB case
• DEEP COOL RGB Convertor, 5V ADD-RGB to 12V RGB Transfer Hub (to sync case lighting)
• ROG Evolve Gaming Mouse
• ROG Flare Gaming Keyboard
• ROG Balteus QI LED Mousepad

• Windows 10 64-bit OS
• BIOS is ROG UEFI BIOS Utility Ver 2.17.1246 (ROG Effects are enabled)
note: I am not currently overclocking the system

Some specific issues I've had:
Lighting randomly stops working under both Asus Aura and Armoury Crate
Unable to reliably reinstall Aura and/or Armoury Crate - they sometimes just show up, (Aura usually does allow a reinstall, but not always - then it will run for a few days, and then just stop responding)
G.Skill RAM works, but AURA and Armoury Crate have never 'seen' them, even though they are Aura compatible
When it does work, Aura sometimes reports the Balteous pad as a motherboard

I have tried several methods that I found throughout this (and other) forums, such as:
• Removing the LastProfile.xml (
• Using CCleaner to uninstall the programs and clean the registry (
• Uninstalled ALL Aura (and even all ASUS) software, gone through the registry and found all Aura or Lighting Component files and removed them, then cleaned the registry with CCleaner (
• Uninstalled all Asus programs and reinstalled after checking the "This file came from another computer..." setting in Properties (
• Cleared the CMOS before reinstalling
• To try to get the RAM synced, I tried to follow these instructions, but do not have a SPD setting in my BIOS (

This has been driving me crazy for months. If I would have known that I would have this many issues with the lighting, I would have purchased other products. Does anyone have a solution to get this thing running properly?

Thanks in advance


Level 7
I can't help with all of your issues as Armory Crate mostly works for me. Only issue I'm having is I can't select my motherboard, I can change effects fine and even Aura Creator works....sorta. What I did run into when I first built my machine is the Thermaltake case would flat out not work. Months of back and forth and swapped components. Ultimately to get the case to sync up I had to completely remove the Thermaltake controller by getting an ARGB hub and new fans with standard connectors.

Reinstall windows and only install armory crate for asus control software. I was having all kinds of weird aura issues before doing this. Literally every piece of hardware I have is aura snyc compatible and it all working 95%. That 5%, sometimes my mouses led stop reacting and I have to replug it in to reset it. Occasionally the mouse leds not reacting trips up the rest of aura sync, but it goes back to normal after re-plugging the mouse.

also keep in mind crate is still in beta but they are improving it daily.

Level 7
The answer is NO. You will find it easier and much faster just wiping the whole OS.
components in PCPartPicker
Intel 8700K - 5.1GHz core, 5.0GHz cache, 1.37v
EVGA FTW3 1080Ti Hybrid SLI - 2.0GHz core, 12GHz memory
Asus Maximus X Hero
Corsair Dominator 16x4GB - 3000MHz default XMP 15-17-17-35
Fire Strike 36838 Extreme 25250 Ultra 14464

So I was finally able to wipe and reload the OS. I completely wiped the hard drive and reset the BIOS. Now Armoury Crate is up-and-running, it sees (and properly identifies) my Motherboard, Keyboard, Mouse, and Mousepad.

But the G.SKILL Trident Z RAM is still MIA - it is lit and doing the standard rainbow, but Crate doesn't see it even though it is supposed to be compatible with my system.

Any ideas?