Showing results for 
Search instead for 
Did you mean: 

Crosshair VIII Formula will not post, HDD Code: 02 Post Error

Level 7

  • Ryzen 9 3900x
  • ROG Crosshair VIII Formula
  • GIGABYTE GeForce RTX 2080 Super GAMING OC 8G
  • 4x: CORSAIR Vengeance LPX 32GB DDR4 3000 (PC4 24000)
  • NZXT Kraken X62 280mm
  • Intel 660p Series M.2 2280 2TB PCI-Express 3.0 x4 3D NAND Internal (SSD)
  • Samsung 860 EVO 2.5" SATA III 2TB SSD
  • CORSAIR HXi Series HX1200i 1200W 80 PLUS PLATINUM power source

New system build, first boot went perfectly. Went through BIOS and Windows 10 setup without a hitch. All hardware was detected and running normally. Standards speeds, no OCing. Temps all satisfactory and constant. Once up and online updated the BIOS, Windows, and all of the drivers to the newest versions. Went through a number of the standard soft restarts that come with a new build setup, no problems. Got to the point where it was time for bed so I shut down completely and unplugged the power and all other cables so there were no unexpected updates or power issues overnight. The next day I plugged everything back in and attempted the first cold boot since setup, which stuck in the post. Everything seems to be getting power and functioning. The display on the motherboard goes through the CPU and VGA post okay but when it gets to the HDD post it hangs on "HDD Code: 02" then gives the "Code: 02 Post Error" and just stops. Does not finish microcode loading and does not proceed to BIOS/system boot.




  • Reflashed BIOS to both versions available on ASUS support (Version 0702 & Version 0803).
  • Tried: CMOS reset, slow mode reboot, Safe BIOS mode reboot
  • Tried all configurations for the LN2 Mode Jumper
  • Reseated everything except the processor (don't currently have more thermal paste but the system booted fine the first time so issues in the CPU are unlikely).
  • Tried minimal setup with just processor, 1 stick of RAM, Vid card, and 1 storage device (tried each SSD, a magnetic HDD, a USB drive, and no storage at all, all separately).
  • Have checked all components (except CPU) individually on another system. No issues.

My only guess at this point is maybe an error in the newer BIOS versions. Does anyone know if the factory BIOS is different from the versions available for download?

Level 7
Also experiencing this kind of issues, on a ASUS ROG Crosshair VIII Formula. When i need to restart the pc, it just keeps on trying to post until it after 5-6 attempts stops at "HDD Code: 02" and "Code: 02 Post Error". If i clear CMOS and removes the power cord, and then wait 1 minut. if lucky it boots the bios into safemode and boot just fine. I have one time experienced same issue on a cold boot with the Code: 02 Post Error, but a simple restart on the case fixes it.

Ryzen 9 3900x
ROG Crosshair VIII Formula
MSI GeForce RTX 2080 Ti Lightning Z
4x F4-3600C14Q-32GTZN
Corsair Force Series MP600 2TB
Samsung 850 EVO 2TB SSD

You have a single M2 drive and read few times that having something in SATA 1 may cause conflict.

Make sure you have nothing plugged in SATA 1 and retry. If you have two m2 then SATA 1 & 2, clear them, and plug into other ports available.

Level 7
I have this problem as well and have tried all the troubleshooting steps as listed in the above posts and have also tried swapping out all components including psu and cpu for known to be good or brand new components , I ran the board with it's temporary 3600 cpu ( soon to be 3950X ) for around 4 weeks then one day after installing a new game and doing initial setup on it the computer crashed and went to a black screen and fron onwards all I get is this error 02 on the display screen .Anyone have any ideas ?.

Level 7
I have found the reason for the post 02 error now , it was a faulty hdmi cable so if you have this problem and you use hdmi it should be on your checklist .

bowdog522 wrote:
I have found the reason for the post 02 error now , it was a faulty hdmi cable so if you have this problem and you use hdmi it should be on your checklist .

Same here. Struggled with the 02 error code on a new board. Returned and replaced with a 2nd board..same issue. Then I removed my HDMI switch and cabled the RTX 2070 Super DIRECT to my monitor and the board booted with no problems. Once boot was complete and the BIOS configed, I was able to reinstall the HDMI switch without further 02 error code stops.

bowdog522 wrote:
I have found the reason for the post 02 error now , it was a faulty hdmi cable so if you have this problem and you use hdmi it should be on your checklist .

Same error with the Displayport, it was solved by replacing the cable.

Thanks in advance

-ROG Crosshair VIII Hero[Wifi]
-radeon rx 5700 xt
-Monitor samsung 49 inch

Level 40
Code 02 is the board sitting in BIOS...if nothing else is happening maybe check display cables etc.....display chain in general


I'm experiencing the same issue as you all. I have used 2 different video cards, most recently I installed a MSI GeForce RTX 3070 Ti SUPRIM X 8G. both NVIDIA cards gave the 02 error. my older card is a EVGA. my processor is AMD Ryzen 9 5950X. What I discovered is the issue is with the PCI x16_1 slot. When the video card is installed in the PCI x16_2 slot, it doesn't give that error. I would expect ASUS to have discovered this by now but maybe I'm the only one that has discovered that workaround. Hopefully that works out for you. It still sucks because I can't take advantage of all those lanes.