cancel
Showing results for 
Search instead for 
Did you mean: 

CPU Fan Error

V_S
Level 8

ROG Crosshair VIII Dark Hero, AMD 9500x, Arctic Liquid Freezer II 420, Fractal Design 7 XL

PC has been working fine since I built it 1 1/2 yrs ago. Started getting CPU Fan Error last week after a normal shutdown.

AIO is plugged in to the AIO pump header on motherboard. CPU_fan header on motherboard is plugged in to nexus+ 2 fan hub.

Troubleshooting I've done so far:

Updated to latest BIOS, tried another AIO, setting CPU fan speed to Ignore results in boot straight to BIOS.

I can't get passed the BIOS. It won't boot to windows.

I'm out of ideas. Any suggestions?

6,432 Views
10 REPLIES 10

Koyote7667
Level 9

In bios, go to the boot section, and find where you can see your aio pump settings. Make sure your pump and cpu fan is on PWM mode.  put IGNORE, and youll be fine. The artic doesnt have a aio rpm, and your board thinks your pump or fan is down. Obviously make sure its working first (Watch temps, visually see if the little fan on the pump head is spinning)  I had this issue when i swapped to the Artic aio. Yours , having been working before, id really make sure your pump and fan is working. Cheers. 

Unfortunately, this did not work for me. It still only booting straight to bios due to CPU_fan speed setting set to Ignore. If not set to Ignore, it stops at the CPU Fan Error during boot and I have to press F1 to get into bios.

I replaced my Liquid Freezer II 420 with a Liquid Freezer II 420 A-RGB thinking that the old one died on me. That wasnt it. Well, at least I have an extra if it does.

20230420_172138.jpg20230420_172824.jpg20230420_172103.jpg

Murph_9000
Level 14

If you've already set the CPU fan to Ignore on the Monitor tab of the BIOS, there's something else that's going on with your boot failure.  Updating the BIOS probably reset things to defaults, and it's possible that one of the defaults has changed between BIOS versions.  I'm thinking it might have something to do with CSM and secure boot options.

Ideally, you want to have CSM disabled, secure boot enabled, and the OS type for secure boot set to Windows UEFI.  That does depend, however, on your Windows install being a UEFI+GPT install.  If it somehow ended up as a legacy BIOS+MBR install, you'll probably need CSM enabled and secure boot disabled.

Looking to the future and security, it's better to not use CSM, just it may be necessary to use it if CSM was enabled when you installed Windows.

Before you start tweaking boot options, I suggest resetting the config with "load optimised defaults" (F5 in BIOS setup), to eliminate the possibility of some obscure option preventing the boot.  Then set the CPU fan to ignore in Monitor, save and try a boot.  If that fails, try the CSM and secure boot stuff.

I only updated the bios because I thought that's what was causing the CPU Fan Error that showed up out of nowhere. One day it was fine and the next day the error showed up.

So first, I loaded the optimised defaults and set the CPU fan to Ignore in Monitor. This didnt work for me.

Then I tried the CSM and secure boot and that also didn't fix the issue.

20230420_175435.jpg20230420_175458.jpg

 

V_S
Level 8

So this is weird. I moved the cable from the CPU_Fan header that is connected to the nexus+2 fan hub and hooked it up to the CPU_Opt header. I then plugged in one of the radiator fan from the extra AIO to the CPU_Fan header. Booted the PC and changed the CPU Fan Speed from Ignore to Monitor, saved and exit. Booted and no CPU Fan error but it goes straight to Bios. Fan speed was around 800 rpm. So now I'm totally confused as to what is wrong with this motherboard.

That was my bad. Get into bios, go to "monitor".  That is where you will see "ignore" or set the RPM speed lower. In "monitor" set the aio pump and cpu fan to PWM.  Thats my bad, wrong header. I HIGHLY doubt anything is wrong with your MOBO... Highly doubt. Id also put back anything you changed in the boot menu. Go to MONITOR. Go to cpu fan, and aio pump. Move to pwm. See if that will post and work. If not, ignore the one giving you issues. That said, i highly recommed you do verify your pump/aio is working correctly. But i bet it is fine. I dont know if you made a bios update since it was working ok for a while, to now. But, .... again, get into MONITOR. You will see cpu fan, and AIO pump headers. If you know your stuff is working (you cpu temps dont go through the roof in seconds at idle) set to ignore, or lower the looked at RPM. I feel your gear is all fine mate. 

I bought a new Liquid Freezer II 420 A-RGB when I though that the old Liquid Freezer II 420 was the one causing the issue. I only updated the bios when I couldn't get rid of the CPU fan error thinking that may be it. Still having the same error with the latest bios. My CPU temp hovers around 38 degrees celsius so the AIO is working. I don't know why I still cant get passed the CPU fan error. Even putting it on Ignore in monitor only boots straight to bios. I've tried the optimized default and still a no go. I've looked all over and for most people the solution was set cpu fan speed in the bios to ignore but not for my system.

Murph_9000
Level 14

I think you're dealing with 2 separate problems that have landed at more or less the same time.

1. CPU fan speed.  When the BIOS inhibits booting due to this, it's usually at a text screen saying something like "CPU fan error", and to press F1 to enter setup (the exact details may vary, it's been a while since I've seen that error from an AMI BIOS, but a text screen that's not the normal BIOS setup menus).  If your system is just going into BIOS setup directly, that is likely no longer the problem.

2. No boot device.  This one, I believe, just dumps you into BIOS setup directly, which I think is what you're describing after setting CPU fan speed to ignore.  If you're still getting a fan speed error, then something else is needed to get past the first error.  If it's looking like a boot device problem, it's probably something that needs adjusted in the Boot menu (maybe CSM, maybe secure boot, or maybe as simple as selecting the boot device).

So, when you say it "boots straight to bios", are you getting any message saying anything about CPU fan error, fan speed, or anything like that?  Or, is the first thing you're seeing (possibly after the ROG eye logo) the normal BIOS setup menus?  If there's no message complaining about the CPU fan, the problem is unlikely to be the CPU fan.

Do you know if your boot drive uses MBR or GPT partitioning?  Before things went wrong, can you remember if secure boot was enabled?

Finally figured out what is wrong with my PC.

Murph_9000 got it correct. I had 2 issues I was dealing with. 1 was the CPU fan error and the other was a failed boot drive. It would have been fixed sooner had Amazon delivered the SSD that I ordered but got stuck somewhere in lalaland. Cancelled that order and ordered another which arrived today.

Removed SSD and installed the new one. Loaded the optimized defaults in the bios, set CPU fan speed to Ignore.Plugged in USB with windows 10 install. Rebooted and straight to windows setup and installed windows.

So Koyote and Murph are correct. The fix for the CPU fan error is to set the bios CPU fan speed to Ignore. Thanks guys.