Showing results for 
Search instead for 
Did you mean: 

Ryujin 360 USB storage

Level 8
Hey there,

When i installed Ryujin 360 a usb storage device appeared in my peripherals. It created for me a few issues, Aida64 have problems digesting it, aida64 freezes for a long time each time it access that device, if i do a HDD sti device dump (in Aida) it also freeze a very long time on that device:

[ HDD: AsusTek ROG RYUJIN USB Device ]------
Device Path = \\?\usbstor#disk&ven_asustek&prod_rog_ryujin&rev_1.00#8&182fcd56&0&00000000001a&0#{53f56307-b6bf-11d0-94f2-00a0c91efb8b}

It is assinged as my H: drive, each time i open file explorer, it take a long time to scan that device. Also, often that usb device become unresponsive for a long time.

I have the latest livedash and firmware for the Ryujin. Sorry if that post is not very clear, english is not my first language.

Everything else works perfectly.

Any help would be appreciated,


COOL: ASUS Ryujin 360
PSU: EVGA SuperNOVA 1000 T2
MOBO: ASUS ROG Maximus XI Extreme
CPU: Intel Core i9-9900k @ 5.1 GHz
MEM: 4x8GB Corsair vengeance LED 3400
SSD: Samsung 960 Pro 512GB PCIe M.2
VGA: EVGA GTX 1080 Ti SC2 Hybrid

Windows 10 pro 1809

Level 8
Just go into Windows Device Manager under disk drives and disable it. It will not affect cooler performance.

mdzcpa wrote:
Just go into Windows Device Manager under disk drives and disable it. It will not affect cooler performance.

You are awesome, thank you.;):○:d

mdzcpa wrote:
Just go into Windows Device Manager under disk drives and disable it. It will not affect cooler performance.


Level 8
If you would please clarify, your cooler was connected when you installed Windows and it created a separate small drive on your OS drive?
There is another thread about this on these forums but he was not having in issues.
I don't own this cooler, but I would uninstall the software, delete the drive in Windows drive management, expand C drive to include this extra space and re-install the software , it should then install in the correct place on your C drive. But as I say I don't have one of these coolers to test myself.

About AIDA64, at the top "reports" click on submit report to AIDA, it will take a little while to complete the report, enter your name and email address and submit report.
They have always been very responsive to correcting issues with new hardware.

Level 8
It's not a partition of any drives, it's a seperate USB device ( The icon to eject it is there but it always hang if i do). In device management it's considered as a Windows Mobile Device, not a usb one, weird (i tried disabling it, still appear as a usb).

Already tried uninstalling AI Suit 3 and Livedash, no go.

I cannot find it under USB Controllers. Already submitted a report to AIDA.

Other than that the cooler is performing very well. It's not game breaking, just annoying.

Thank you for all your replies, i will continue to investigate.

EDIT: I disabled it under Disk drives, will see what happens.


Level 8
Disabling it fixed a few of my issues, so far AIDA is working ok, i'll know more in a day or two.

Thank you for all the help.



I have the same cooler since yesterday and saw the same "extra volume" (C = OS, D = Games and E = AIO cooler)

I think it is the internal storage of the AIO cooler, because you can save images and gif's to the cooler so it can display it on the OLED screen of the AIO Cooler.

So far I don't have any issues with it, but I was curious about this extra "E drive" created, so I start googling and came accross this thread 😉

But in your case, just unplug the usb cable from the cooler I guess... (I guess the usb is only used for Aura Sync and uploading jpg/gif) because power comes from sata connector and pump-speed readings via cpu-header (PWM)

I GUESS it cannot destroy your AIO 😛

Level 7
Well if you are upgrading to Windows 10 1903 then you MUST disable the USB device because when it scans your computer it will fail due to picking up this USB device. Tried to unplug it but the 60mm runs maxed out and the 120mm don't spin 😞 so have to disable through device manager.