cancel
Showing results for 
Search instead for 
Did you mean: 

USB 3.1 gen 2 ports shared?!

Wobbler
Level 7
So it seems the 2 ports share controller, as having USB 3.1 gen 1 hub connected, with phone and calibration camera(not in use), to the A type port more than halved USB-C Hard drive write speed connected to the type C port. While connected to the hub the drive maxes out the gen 1 speed, and alone in A or C it works normally. Now need to test the port on the MB... Hmm.

Windows restart seems to have fixed the write speed issue, no idea why. Now it works normally in the USB 3.1 gen 2 IO panel ports, as well as in the MB port with USB-C cable, with or without the USB hub connected. Something really odd was going on, as there's no way bandwidth was the issue to start with.
3,470 Views
4 REPLIES 4

Wobbler
Level 7
So I tested the USB 3.1 gen 2 ports with a 2 drive raid enclosure (ASM1352R, 2x2TB EVO SSD raid 0). MB has three USB 3.1 gen 2 ports, that are divided to a two separated controllers: ASMedia (ASM????) = type C + A and AMD chipset (X399) controls 1 on the motherboard PCB -> type C.

Since the ASMedia(ASM????) is split to 2 ports (used 1), I suspect it is causing the ports to be ~10% slower on all test with crystaldiskmark when compared to the AMD one, also the X399 chipset has the advantage of direct connection to the CPU.

1950X 3700Mhz, NUMA. SMT off. 64GB/4 3200Mhz CL14 CR2
Single thread/queue(1) sequential write ~562MB/s, single drive enclosure(ASM1351) ~375MB. "file copy"
Two thread/queue(1) sequential write seems to cap something at ~875MB/s, got about the same results with high queue number tests.
Sequential read speeds hover around the 700MB/s ± 20MB/s on the tests.
Test results seems to vary somewhat, also managed to get the enclosure to get stuck in super slow speed somehow.

Need to test the SSD raid speeds some day on the PCIe add on card that I use for spinning disk raid, and on the MB sata slots (all in use).
Now waiting for USB 3.1 gen 2 to PCIe NVME enclosures to become more common/available (JMicron JMS583, ASMedia ASM2363), and large size NVMe to be a bit more affordable.

+Ran into some serious PC slowdown issues with large thread count test while testing on the X399 USB port, while the ASMedia ports worked normally, waiting for reply from AMD support, this also happened with the single drive enclosure.

every usb implementation ever has been 2 ports per root hub.

jologskyblues
Level 8
Yeah. I only found out a couple of years ago that USB speed advertised by these companies is not per port but rather per controller shared by ports.

Wobbler
Level 7
Yeah the usb 3.1 gen 2 ports in the back are connected to a single ASmedia controller, but still if only 1 port is used it could work "faster". The single usb 3.1 gen 2 slot on the MB is faster handled by the x399 chipset (+CPU), but causes some issues with certain test program... then again I could not repeat the issue with same parameters with the same win executable the problematic test uses. Still waiting for possible AMD response, but finally got "tech" to forward the issue for testing.