Showing results for 
Search instead for 
Did you mean: 

ROG Zenith Extreme (X399, socket TR4) - info, experience, updates

Level 13

AMD showed new highend chipset named AMD X399, this is specially for HEDT segment of CPUs. Many, many years AMD was not active in this segment. But the RED team is back!! The socket is named TR4, its version of the same size socket for servers, for AMD Epyc processors. This socket/LGA is huge, inside we can count crazy 4096 pins!! But not all these pins are electricaly active (its my idea, why Epyc cant work inside TR4)

CPUs Ryzen Threadrippers will be relase in configurations up to 16C/32T this summer.
Great bonus of this platform are numbers of PCIe 3.0 lines inside the CPU, which it offers 64! CPU and this board has support of quadchannel RAM DDR4 up to capacity 128 GB (I heard, in theory, this CPU can working with more)


Rights near RAM DIMM slots we can see special slot named DIMM M.2 slot. This special feature you can know from Maximus IX Apex. Its great value for NVMe M.2. Besided Threadripper has direct lines to CPU for NVMe, so lower latency 🙂 Two 8-pins for CPU is needed for serious OC and specially for LN2, switchs to PCIe slots, voltage measuring points, buttons start+reset and more. Example front USB3.1

SATAs and also U.2 port

In same wawe as Rampage X299, there is dash board for information about frequency, temperatures, speed of fan etc...Nice bonus is special LAN card ROG Aerion 10GB/s

Integrated IO shield, buttons for CLR CMOS, BIOS Flashback, backlighting of audio outputs, USB3, USB3.1 and looking at the Wi-Fi! This Wi-Fi support last standard 802.11ad!

At the board are features for driving your fans, cooling, include wattercooling and of course, dont forget at RGB AURA/AURA Sync or 3D print supopor.
Im looking forward sooooo muuuuch and promise, LN2 OC results coming 🙂

video from Linus (ah, this is the guy who broked few pins in socket ,-D)
Who knows me, knows me ;)....AMD 3000+, AMD x2 4600+ EE, AMD X4 955 BE C2,2x AMD X4 965 BE C3, AMD X4 970 BE C3, AMD x4 975 BE, AMD x4 980 BE, AMD X6 1090T BE, AMD x6 1100T BE, 2x AMD FX-8120, 2x AMD FX-8150, FX-6300, FX-8300, FX-8320E, FX-8320, FX-8350, FX-8370, FX-8370E, FX-9370, FX-9590, AMD A8-3850, AMD A8-3870K, A8-5600K, A10-5800K, A10-6800K, A10-7850K, A10-7870K, A 5150, Athlon x4 860K, Intel i7-5960X, i7-6700K, Intel i7-4770K, Intel i7-980x, Intel i7 2600k, Intel i7-3770K, i7-3930K.
118 REPLIES 118

Just looking at the manual, a single module should be A1. 2 modules should be A1 and C1. Does A1 + C1 work?

a1+c1 does not work
a1 does not work

Level 7
Have you tried clearing CMOS?

Level 7
Just done one run so far with current settings:)
This time I did not have core performance boost on lol.
Thank you everyone that is working hard to make this
a amazing motherboard.
32041 Fire Strike physics score (#10 at the moment) ^^

Anyone else getting something that looks like cpu throttle during p95 testing?
After 3 min running, my cpu is starting to downclock then go back up... and it slowly gets worse and worse.
I have set cusom pstates in the bios.
My temps are fine (max 60c, ryzen master), i have the new EKWB and an extra fan blowing over the vrms.
Im at 4ghz 1,415 vcore now, i can get 4,050 but after that i cant pas p95. 1 core seems to constantly crash when i pas 4,050.
0601bios 1950x ddr4 at 3466mhz cl 14

Level 7
I had similar thing happen on 2nd Fire Strike benchmark CPU clock going from max to 2.2 and up again.
Not sure it works for you but I think I got it to vanish now cause I raised voltage to memory a bit.

Here is the thought I had.
Most memory is made after Intel spec.
Some functions on X399 / X399 chipset makes voltage on memory drop,
not found what it is yet thou.

At default 1.2 it gets 1.1 something and when I set 1.35 it shows 1.308.
Most memory following Intel spec is used to getting 1.35 all the time when
XMP is enabled and 1.2 all the time when it is a default.

So maybe 😛
-Some kits handles this fine.
-Some kits does not like this at all.
-And some kits is a mix between the two.

My memory seems to accept most settings and post even with low voltage (knock on wood).
But to get memory to stay at 1.35 minimum and be very similar to my Intel PC´s,
I have set it to 1.38 and now it stays at 1.351.

This is also something to try if anyone is having trouble with kits I guess. 🙂

It was my high vrm temps that was cause of the cpu throttle.
I set the digi power+ control in bios to standard settings, put heatsinks and a fan on the "back heatsink" of the vrms.
Still my vrm is at 78c full load,but now i can run p95 without throttle.
Monoblock next.

Level 7
That is really good to know and glad you solved it. 🙂
But is your IO cover fan running (COV FAN) It has a profile at end of q-fan settings.
I think it does not start until 60C by default cause fan stops. But it can go really high rpm if wanted.
Maybe if it started slightly earlier at lower speed. Mine is actually kinda silent until
very high speeds, but I guess depends how silent system is. Maybe it helps a little.

Yes it was running full speed. 😛

Level 7
Noticed AMD updated their installer for X399 chipset, still same version thou. 🙂