cancel
Showing results for 
Search instead for 
Did you mean: 

ROG Zenith Extreme (X399, socket TR4) - info, experience, updates

FlanK3r
Level 13


AMD showed new highend chipset named AMD X399, this is specially for HEDT segment of CPUs. Many, many years AMD was not active in this segment. But the RED team is back!! The socket is named TR4, its version of the same size socket for servers, for AMD Epyc processors. This socket/LGA is huge, inside we can count crazy 4096 pins!! But not all these pins are electricaly active (its my idea, why Epyc cant work inside TR4)

CPUs Ryzen Threadrippers will be relase in configurations up to 16C/32T this summer.
Great bonus of this platform are numbers of PCIe 3.0 lines inside the CPU, which it offers 64! CPU and this board has support of quadchannel RAM DDR4 up to capacity 128 GB (I heard, in theory, this CPU can working with more)

MOTHERBOARD

Rights near RAM DIMM slots we can see special slot named DIMM M.2 slot. This special feature you can know from Maximus IX Apex. Its great value for NVMe M.2. Besided Threadripper has direct lines to CPU for NVMe, so lower latency 🙂 Two 8-pins for CPU is needed for serious OC and specially for LN2, switchs to PCIe slots, voltage measuring points, buttons start+reset and more. Example front USB3.1


SATAs and also U.2 port


In same wawe as Rampage X299, there is dash board for information about frequency, temperatures, speed of fan etc...Nice bonus is special LAN card ROG Aerion 10GB/s



Integrated IO shield, buttons for CLR CMOS, BIOS Flashback, backlighting of audio outputs, USB3, USB3.1 and looking at the Wi-Fi! This Wi-Fi support last standard 802.11ad!

At the board are features for driving your fans, cooling, include wattercooling and of course, dont forget at RGB AURA/AURA Sync or 3D print supopor.
Im looking forward sooooo muuuuch and promise, LN2 OC results coming 🙂


video from Linus (ah, this is the guy who broked few pins in socket ,-D)
Who knows me, knows me ;)....AMD 3000+, AMD x2 4600+ EE, AMD X4 955 BE C2,2x AMD X4 965 BE C3, AMD X4 970 BE C3, AMD x4 975 BE, AMD x4 980 BE, AMD X6 1090T BE, AMD x6 1100T BE, 2x AMD FX-8120, 2x AMD FX-8150, FX-6300, FX-8300, FX-8320E, FX-8320, FX-8350, FX-8370, FX-8370E, FX-9370, FX-9590, AMD A8-3850, AMD A8-3870K, A8-5600K, A10-5800K, A10-6800K, A10-7850K, A10-7870K, A 5150, Athlon x4 860K, Intel i7-5960X, i7-6700K, Intel i7-4770K, Intel i7-980x, Intel i7 2600k, Intel i7-3770K, i7-3930K.
208 Views
118 REPLIES 118

Mikan02
Level 7
Updated to 9980 without issues:)
With same settings memory read went up from about 90500MB/s to around 91000-91500MB/s.

Managed to do some runs at 4150, thou need better cooling and more voltage to get properly stable.
Fire Strike Physics Score 30691 and some other scores went up too^^
https://www.3dmark.com/fs/13429431

Tested AMD Ryzen Balanced power options and it is almost like high performance,
but CPU speed just drops to 90% instead. So it increases with overclock.


On Doom both OpenGL and Vulcan is super smooth, seems id Tech engine really likes TR.
Some of those cores most likely went active cause of the screenshot but still. ^^
It actually looked smoother than my 6950X, only had one hick up when you wake up at start. 🙂

Mikan02
Level 7
Noticed some updates over at support page that got a added couple days ago.
In case someone else missed them too. 🙂
https://www.asus.com/Motherboards/ROG-ZENITH-EXTREME/HelpDesk_Download/
AUDIO
-Realtek audio driver
LAN
-Aquantia 10g Ethernet driver
Utilities
-ASUS Ai Suite 3
-ASUS Aura
-ASUS LiveDash
-Mem TweakIt
-RAMCACHE II
-ROG CPU-Z

Mikan02
Level 7
Updated to 9906 without issues yesterday.
Very similar memory performance with same settings, maybe slight better latency.
First time I tested it was 13ns difference between my 6950X and 1950X,
now it is 10.5ns ^^

Latest Nvidia driver had some increased performance in Fire Strike and Ice Storm,
it does not solve issue at lower resolution but it is slightly better.

Filled out another feedback form to Nvidia, feel free to fill out one too if you have
similar issues or other GPU related issues.
http://surveys.nvidia.com/index.jsp?pi=6e7ea6bb4a02641fa8f07694a40f8ac6

My TR@4150 Fire Strike Physics Score 31185 ^^
https://www.3dmark.com/fs/13456813

Hopefully EK-MLC release later this year, not seen date yet. 😛


In case someone bump into similar issue with Corsair Link and the H115i or similar.
When I updated to latest version I bumped into Code 52 cause I have Windows UEFI mode on.
-Uninstalled latest.
-Installed a earlier version got same issue again.
-Installed update to latest still same.
-Updated manual USBXPDriver in Device Manager to the one found in this post over at Corsair
by a user named red-ray and it started like normal right away after.
File name in post --> hydros7289-3.6.zip
Device name for me changed to --> Corsair Hydro Series 7289 USB Device
http://forum.corsair.com/forums/showthread.php?p=856104

You can check version with command prompt (admin):
dism /online /get-driver /format:table

Mikan02
Level 7
@starlightknight and inc77
Not sure if it helps but here is link to latest beta 9910, I had trouble downloading it too. 🙂
https://drive.google.com/file/d/0Bz2VRRbLPrZnR093RkJpOUlQelk/view?usp=sharing

Mikan02 wrote:
@starlightknight and inc77
Not sure if it helps but here is link to latest beta 9910, I had trouble downloading it too. 🙂
https://drive.google.com/file/d/0Bz2VRRbLPrZnR093RkJpOUlQelk/view?usp=sharing


Unfortunately still same issue...

Adding to the list of BIOS issues:

This is probably an uncommon issue, but -

I really appreciate the PCIe on/off switches as it makes troubleshooting and isolating issues with specific cards much easier, especially for certain cases (*glares at the Corsair 900d*) where screwing things in/out is a pain on the PCIe slots.

One thing I noticed in my struggles with PCIe cards was that if you have a GPU in the bottom slot, you can't post with it (I know this is not the recommended slot, as you're limited to x8). The board will hang on Code 92 Post VGA BIOS and will not proceed. In this case, I was testing slot by slot and had the other slots disabled. As long as its not the only card, the card works fine in this slot once in the OS, but will not work until you get there. In the case of failures, this bug can limit your ability to isolate the issue using the switches, and could also be misleading.

Edit: I noticed that the LED display lists this code while everything is running normally - so maybe the code is not related, just the output doesnt show?

Mikan02
Level 7
Updated to 9910 without issues, thank you for all the updates by the way. 🙂
-Memory Optimized phase control work better than Extreme for some reason on this version. Tried to swap a few times. :confused:
-Memory latency seem slightly slower with same settings.
-Managed to add another 50 MHz on CPU at kinda low voltage, increased stability I guess.

My TR @4200 Fire Strike Physics score 31543 ^^
https://www.3dmark.com/fs/13470054

Edit:
Forgot to mention something I noticed on earlier. Clear Cmos button on backside does
not reset Memory Access Mode to Distributed if it is changed to Local.
But Load Optimized Defaults does, so remember to do both before updating. 🙂

@starlightknight
Maybe helpful.
On my 750D´s I increased the standoffs from 6mm+3mm to 9mm+3mm.
Used older 8mm+4mm and added two tiny 0.5mm washers between pc case and the standoffs to get 9mm+3mm instead.
Now it just clears the rubber grommets even with the thick back-shield and all the GPU locks on motherboard works.
GPU locks would probly work best with 10mm+3mm but at 9mm+3mm
they just need a little help and IO back panel is only unnoticeable slightly offset.
Did this on two 750D (one with the Zenith and one with a RVE10).

@ASUS - here is all the information I've collected from my IOMMU/Virtualization issues noted previously. Please pass on to engineering.

lspci -tv: https://pastebin.com/u1N46P5G
lspci -vv GPUs: https://pastebin.com/qvpbDV4p
lspci -vvv (Full): https://pastebin.com/hkZXzeAY
IOMMU Groups: https://pastebin.com/RhXM9uPt
KVM/Libvirtd Config: https://pastebin.com/EvJGe5BM
KVM Log: https://pastebin.com/sb21r4EH
VFIO DMESG (on VM start): https://pastebin.com/HqUyAT1y
/proc/interrupts: https://pastebin.com/G8pzScxZ

OS: Linux Mint 18.2 Cinnamon Edition (Ubuntu 16.04)
CPU: AMD Ryzen Threadripper 1950x
MB: Asus Zenith Xtreme (BIOS 0503)
MEM: 8x16GB (128GB) Crucial Ballistix BLS4K16G4D240FSC
GPU: 2x EVGA 1080Ti FTW3 Hybrid (No SLI - GPU2 bound to VFIO for VM passthrough)
Other: Inatek USB PCIe (KTU3FR-5O2U, disabled due to BIOS bugs), Supermicro AOC-SAS2LP-MV8 8-port SATA, Asus 10GEth PCIe (Bundled w/ Zenith), Ceton InfiniTV 4 PCIe

Kernels tried:
4.8, 4.10, 4.12, 4.13rc6

Versions tried:
QEMU 2.5, Libvirt 2.5
QEMU 2.9, Libvirt 2.5
QEMU 2.10rc4, Libvirt 3.6.0

(same result on all of them)

Root problem: Pass-through GPU stuck in D3 state, no output. VM hangs. Let me know if there is any more information I can provide.

Some additional observations:

1) IOMMU currently fails to isolate the PCIe x4 slot, it gets grouped in with a bunch of other devices. The rest of the slots do seem to isolate properly. This can be observed in the logs provided in the previous post. The x4 slot is 05:00.0 which gets tossed into group 12 with a bunch of other stuff.

2) Suspend/resume issues: Computer fails to wake from sleep with a 1080 Ti. I am not overclocking my build or memory when observing this, so that's not related. Full specifications in the previous post

3) A handful of these issues have manifested themselves in different ways across the common X399 motherboards. This may point to some of the issues being bugs in AMD's AGESA base code. However, not all of them at least seem to be - for example, some users on the previously linked reddit thread reported observing tons of PCI bus errors in their logs that I have yet to see. It remains unclear how much of the bug(s) are chipset firmware vs. bios. There definitely seem to be a handful of PCIe related issues though considering some cards like the USB PCIe controllers cause the board to not even boot. It also is worth noting that this particular issue has been confirmed on other X399 motherboards as well.

4) Issues have been reported to AMD as well but they have yet to comment on their forums: https://community.amd.com/message/2820922#comment-2820922

Other thoughts: Some acknowledgment that my report on these issues has been received and passed on to engineering would be nice. I've seen ASUS staff posting in other threads in this sub-forum, including in the last 24 hours, and actively in this thread up until the point that I started providing a bunch of bug reports on broken functionality. Since then there's been crickets chirping. No one has responded to my actual support tickets that I filed last week either. It is frustrating when you have a $1500+ broken build and both AMD/Asus are quiet on the issues. I understand that there will always be bugs at first on initial product releases, and I'm fully willing to work with you on getting them fixed and provide any information necessary to do so. Complex issues take a little time to resolve and I'm not demanding immediate fixes or anything, but it would be nice to know things are being looked into.

Newer kernel but your setup is quite similular to mine. Curious, did you run into any problems booting with both 1080TI's? Board won't even post for me https://rog.asus.com/forum/showthread.php?98620-CPU-upgrade-Threadripper-should-be-called-Hair-rippe...