Showing results for 
Search instead for 
Did you mean: 

RAID controllers that ACTUALLY works with Threadripper

Level 7
Now after the fiasco with the X399's onboard RAID where you can enable it, but you cannot boot from a non RAID disk, I am forced to look at solutions that will let mee get around this problem.

So what I am looking to do, I need a controller that will work with Threadripper and that supports RAID 1 for Windows and SATA Harddrives and SSDs.
I have heard of the classic Perc style controllers, but these are apparently classic problem headaches if you introduce them to the Threadripper platform.
I would also like to avoid the trouble that is known as yucky Windows software RAID.

Level 7
I am using AMD raid 0 while I am typing this which is also supposed to support Raid1

This is the board

Here are the drivers and manual

Gettinther wrote:
I am using AMD raid 0 while I am typing this which is also supposed to support Raid1

This is the board

Here are the drivers and manual

Not to be the complete guy to derail your train, but the issue with the onboard RAID is yes you can set it up.
But unless you RAID the drive for your OS (I have a single SSD, not 2.) that SSD will disappear from the boot list and you cannot get the OS loaded, I already tried to force MS' hand without any luck.
So then I am keeping those ports in AHCI and I intend to have my storage discs on a separate controller with a simple RAID 1 setup, I did consider the LSI card, but I was worried about strange quirks and issues though.

MegaRAID 9260 here with 4 Disks in RAID5 and it can boot no problem. (Windows 10)

Ihave a 9267-8i and cant get thr webbios to load. Tried legacy mode and i see and have the ctrl+h option but it never loads up the webbios. Any ideas anyone?

You can in fact use sata raid, and boot from a non-raid nvme. But the tools are a mess and they pretend like you can't. It's a bit of work:

Download https://

AMD RAID Installer (SATA RAID Only) 461 MB 6/6/2018

It will extract to C:\AMD.

The install will fail saying "Windows is currently installed to an nvme disk; upgrading the raid driver will make this OS unbootable. Please load Windows on non-nvme disk. Raid installation will now abort". Wtf AMD?? How dumb can you be? Note that this is the installer that says "This RAID package permits for a standalone NVMe boot device with a separate SATA RAID storage array." In direct contradiction with the error message.

Run "C:\AMD\AMD-RAID-Chipset-Drivers\Packages\Apps\RAIDXpert2_BR\W7\setup.exe"

Try to log in with admin:admin, Submit button will not work. Need to update drivers.

In device manager under Other devices, I saw 3 RAID devices.

I did update driver on each, and picked the C:\AMD folder, and the system found and installed the appropriate driver (I think??)

But when I updated one device, another unrecognized device would pop up. I updated all of those as well from the C:\AMD folder and eventually I ended up with 3 AMD-RAID Bottom Device, 3 AMD-RAID Controller [storport] under Storage Controllers, and AMD-RAID Config Device under System Devices.

Then I was able to log in to Raidxpert2 using admin:admin, then change my user name and password.

I saw my disks, but I was not able to create any RAID 1 volumes, not even JBOD! Didn't matter what settings I chose, whether I tried to retain existing data or not. Just completely broken. The only thing Raidxpert2 was able to do was delete an existing volume (the legacy, non-raid drive). Thanks.

In the end I created the RAID 1 volume in the BIOS, but unfortunately I lost all my data from my existing drive, because the BIOS has no option to use data from an existing drive (in direct contrast with what's stated in the Asus manual).

AMD and Asus are just useless.

If anyone figures out how to create a raid1 volume while keeping the data on the parent drive intact, please chime in here, I'm sure someone will appreciate the info!

For reference, my setup is Asus Rog Zenith Extreme with Win 10 already installed on 960pro nvme boot drive, and 2 Hitachi 3.5" 3TB drives in RAID 1 for storage.

Level 7
Hmm. Might agree with that. Will have to check back later, and see if my latest trial doesn't work.

I've updated the BIOS, and since then, my LSI 9361-8i has had disk problems (bad disks, fine). Went to reinstall...Windows Server won't boot. This is like the 10th time I'm reinstalling in as many days...I have the SSDs directly connected to the controller now, going to use a previous revision of the controller driver just in case that's the issue...but I'm not happy. Booting from a RAID-1 should be a non-issue here.

And no, I can't just connect them to the SATA bus, as it's in a RAID case...which has no extra drive bays for those kinds of connections (why? because SuperMicro).

Already have the thing set for "Other OS" instead of "Windows UEFI"...should boot.

Level 7
And no, not working yet. Running a consistency check on the drives, right after a full initialization (they are SSDs...this shouldn't be difficult). Will try to swap the RAM and see if that has anything to do with it...might purchase another controller to ensure it's not controller failure.

Level 7
Going to try Installing Linux next. Maybe this is a Windows issue...

Level 7
And f*****g magic.

Ok, so here's what happened.

I used a new USB 3.0 drive for the latest Mint USB install. Not only did it install, it also 'fixed' the enumerating drive process (don't ask me how) of the LSI RAID card on boot up, so that it would detect the drives in an instant instead of going one by one (no idea why it was doing that). I installed it, pulled the USB drive, rebooted, and was greeted by Mint.

Some fun things -> Mint wanted to know if I wanted to install alongside Windows Vista (?) during the setup process. I've only ever tried to install Windows Server 2016 on this machine...and I told Mint to blow away whatever the hard drive config it found. Additionally, I removed the SAS expander (as mentioned before) just in case, to do this install.

Anyway, I reformatted the same new USB 3.0 drive in Mint (haha) and put the latest MegaRaid Windows 10 x64 driver on it (removed unnecessary directories, because Windows Setup seems to get confused by a path of any depth...)...also, I formatted the drive in FAT32 (was using NTFS up until now).

I popped the Windows Server 2016 DVD into the DVD drive (as an aside, still needs to be secured...SuperMicro wants it on the back of the case, and I can't seem to locate / figure out the bracket...I may have lost some screws...), and used the driver on the USB keychain drive to see the RAID card (not that Windows won't let you try and write to it without the driver, apparently, with some success...then kick you out of the setup process...another little gotcha...gotta remember to load the driver first even if you can *see* the drives), and installed Windows. On reboot, Windows Server 2016 loaded.

As has continued to load. Been installing drivers, and applying patches (installing the Cumulative patch right now...going to see if the new MS / Intel Meltdown / Everybody Spectre patch accidentally gets applied and hoses the install. I've installed the MegaRaid Manager (I'm slowly transitioning to soon as I figure out how to make it do something), and run a consistency check on the RAID-1 OS drives...they are consistent.

Some other minor things -> I've installed a Noiseblocker 50mm fan (the faster version, XS-2?) with some jeweler's cement to the side of the RAID card's heatsink to cut down on the temperatures. I've also installed one on the Intel 36-Port SAS Expander. They are now cool to the touch.

But yes, whatever Mint did, it seemed to reset the RAID card settings (or what have you). Now someone tell me why.