Showing results for 
Search instead for 
Did you mean: 

Need help with RAID & non-RAID setup on Zenith Extreme

Level 7
Hey all, I really need some help with my existing setup because exhausted all the troubleshooting tips I can find.

What I want to do is set up a new raid 1 array using two new 8tb mechanical drives. My system also contains one m.2 NVME drive underneath the board heat spreader, and another m.2 NVME on the DIMM card. The m.2 drive under the heat spreader is my c drive and contains my Windows installation. The DIMM drive is only for games so I have removed the card for now. I also have one more mechanical drive in the system. So, I need a combination of raid and non raid. Specifically, only the two new 8tb drives will be in raid 1, everything else is fine on its own.

I've managed to create the array and it's ready to go. But if I boot into windows then Windows doesn't see any of the non raid drives except for my c drive. I figured this might be because the AMD RAID drivers are not installed. However, when I try to install those RAID drivers I get an error message saying that my c drive is NVME and contains my OS and will become unreadable if I install the drivers, so it doesn't give me the option to install. I tried to solve this by using macrium reflect in cloning my entire c drive to the D drive. Then, from bios I change my boot order so the D drive (SATA 4tb) is the only bootable device. But then I get the Windows error "boot_drive_inaccessible", and no matter how much I try to get Windows to boot with the D drive it just won't.

I have tried setting CSM to disabled and enabled, UEFI first. I've created a USB drive with a bootable copy of windows, but on boot it just tells me to remove the media and press any button. I've been scouring forums for the last 2 days trying to figure out how to make this work. I'd really rather not have to do a fresh install of Windows to set up this raid array, so I'm hoping the community can help me find another solution. Who knows? Maybe I'm missing something simple, or maybe I have a very difficult problem. 😄

Thanks in advance! Any help at all is appreciated!

Zenith Extreme
Threadripper 2950x
32gb Corsair vengeance RAM
EVGA RTX 3080 Hydro Copper 12gb
Samsung 970 & 870 evo
WD black 4tb hdd, 2x Seagate Barracuda 8tb

Level 7
I managed to solve it on my own. I enabled nvme raid (even though I won't be using it) at the same time as enabling SATA RAID. Then I was able to install the official RAID drivers package from amd, not Asus.