Showing results for 
Search instead for 
Did you mean: 

Back i/o panel USB port oddity/issues (earlier solder question linked perhaps)

Level 7
All began about 10 days ago when my keyboards led's stopped working on wasd zone (g710+) had it connected to the 2 second lowest (not 3.1/Qcharge) USB ports. I figured the keyboard might have gone bad, warranty had just expired, but I figured I might test it on my powered USB hub (tp-link uh720). After a day or so connected to the USB hub the keyboard leds started working normally.... little odd (been working ever since). So for a while the only USB device connected to the PC has been the hub cable.

Today I got my Asus 1070 back from warranty replacement back (fan(s) failed) and decided to connected my oculus (brand new: warranty replacement screen issue) and connected it to the USB port just above the USB-c port. During installation Oculus software could not find the headset/USB, The Oculus software just blinked the headset/USB in out without getting connection, changing it to a another port fixed the issue. Now I had my USB hub connected to the USB port right next to it but that should not make any difference. So I changed the USB hub to another port and tried checking every USB 3.0 port with oculus app if it could connect to the headset, no issues. So I reinstalled the Oculus software again (some permission issues could not install apps) and had the headset connected to the USB port closest to the USB-c port, and again it failed to find the headset/usb and changing the port fixed it.

Might it be that the connecting solder points in my MB near the USB-c port are linked to the normal USB port above also causing these issues, my other USB ports seem to work normally, have not tested the USB-c port)

I think I need to RMA the MB..... 😞

Level 7
I'd RMA or swap at a store at that stage

Level 7
Hello Wobbler
I would also suggest to send your unit for check ups and repairs
Thank you

So I send my Motherboard to warranty repair/change, anyhow I did take picture of the solder points with my crappy phone camera(would not focus) if anyones interest. The picture don't show well the way the solder is like a bridge between the top solder points, I even remember there was this thin solder strain floating off the MB between those solder points, but that seems to have vanished now, probably while I installed cpu etc on top of the box. While the lower solder points just barely connect, and to the right is the USB-C port.

So I got another motherboard still from the first patch (02.. bios) this one seemed to have shorter screws on CPU socket.... at least there seems to be tiny space between those solder points (straight line about 1/4 mm wide) that were clearly connecting in previous MB. Renesas USB controller drivers still wont load, at least NVMe raid worked from previous installation and Windows 10 worked without reinstallation.

Now Oculus rift still won't work on the USB port just above USB-C port. Now I assume it has some compatibility issues with the "USB bios flashback port" manual has no mention of it not workings as normal 3.1 gen 1 port, keybot II port next to it has some info of USB hot plug not working if enabled in the manual, but it and every other USB port works with oculus rift (default BIOS settings). Windows device manager keeps flashing(refreshing) when oculus rift is connected to the USB bios flashback port. So it might be software issue (BIOS/USB driver), but who knows I'm currently at the beta bios 0801.

Oh and if I remember right the previous MB USB port did detect the oculus rift after the app was installed (rift connected to another port during install) and the new MB won't even detect the rift when connected to the USB flashback port.... how odd. Have to test the port more...

hmmm after trying active usb hub, usb flash, rift sensor and chord mojo(dac, data port) in the USB port (all "worked") after those it also detected oculus rift in it also?!.... reinstall of oculus app left for test purpose.