cancel
Showing results for 
Search instead for 
Did you mean: 

ASUS Zenith Extreme WHEA 17 errors on Windows 11

LoPCY7
Level 7
My main PC has 1950X and my motherboard is the ASUS Zenith Extreme. I wanted to upgrade to Windows 11 as I liked the design more, even though it is an unsupported CPU. After I upgraded to Windows 11 everything seemed normal, every program I tried was operating fine but eventually my computer froze. Nothing was responding, not my mouse, keyboard, anything. Even the small screen on the motherboard which shows the temperature froze.

I have encountered the freezing problem multiple times, but it is a random event. So my computer may freeze after booting to Windows, sometimes while I am browsing the Internet etc. The error I am getting is the following:


A corrected hardware error has occurred.

Component: PCI Express Root Port
Error Source: Advanced Error Reporting (PCI Express)

Primary Bus:Device:Function: 0x0:0x1:0x1
Secondary Bus:Device:Function: 0x0:0x0:0x0
Primary Device Name:PCI\VEN_1022&DEV_1453&SUBSYS_87611043&REV_00
Secondary Device Name:


I have tried everything I can think in order to fix this problem. I have updated to the latest BIOS, updated to the latest chipset drivers, checked every RAM stick separately, removing the NVMe drive, installing Windows 11 to another drive, changing power profiles etc. Sometimes the errors may stop occurring, but after turning off my PC completely and turning it on again (not restarting), the errors come back.

The only time I was able to stop the WHEA 17 messages was when I disabled the PCI Express Root Port in device manager, but this is not an ideal solution. As a note, the PCI Express Root Port which causes the problem is the one with AMD PCI, AMD PSP and USB 3.0 drivers.

In order to use this computer I have installed Windows 10 (temporarily?) on a different drive, as I am not getting any errors in Windows 10 and the system seems stable as I didn't have any freezing problems since.

However, I would like to have my Windows 11 install fixed and if this is not possible, I will move to Linux.

Does anyone have any ideas on how to fix the Whea 17 errors?
3,961 Views
10 REPLIES 10

dstrukov
Level 7
I have exactly the same problem 😞
In addition to those messages, my onboard Bluetooth not working. I see some correlation there ... for the rest , my system is stable

Same WHEA 17 error problem, except no freezing.

System is fully stable in Win11 (since mid November) except from a random tiny stutter twice a day or so (probably because of the thousands of WHEA 17 errors).

92035

92036

I tried everything (like OP) to fix it and I do believe it's a straight up BIOS problem and we need a new "W11 BIOS" because this current one is broken (when combined with Win11).
It looks exactly like the WHEA 17 problem some Alder Lake motherboards (See here and here) had with Win11 and that problem got fixed with a new BIOS. I don't believe any amount of messing around on our side can fix our current problem.

So, ASUS, the ball is in your court. Fix this BIOS please.

*edit*
Somebody suggested it might be TPM and/or Secure Boot related. So I turned off both but the WHEA17 spamming keeps going. So it's not that either (for me).

Mappi75
Level 8

If ASUS can be bothered to make a BIOS with the Agesa that fixes this before the year 2047... Yup

Complete bug reports about this have been filed months ago with zero response.

In the meantime they had the audacity to change the Zenith Extreme mobo page and add a big "Windows 11 Ready" button. Well I'm sorry but unless you bother to fix this ftpm stutter & WHEA 17 flawed BIOS, no it's NOT Win11 Ready at all.

Mappi75
Level 8
i ordered a dedicated tpm addon to avoid any problems.

If it would fix the WHEA 17 spam I'd get one in a heartbeat but it doesn't. (I checked with TPM completely disabled)

+ the ftpm hardly bothers me. It's like one stutter every 4-5 hours.

So I'm not spending anything unless they bother to fix the WHEA 17 mess (as stated above there were Intel systems that needed BIOS updates for the same WHEA 17 problem on Win11). And it seems they won't bother at this point.

Mappi75
Level 8
deleted

SkullyNib
Level 7
Problem solved with today's BETA BIOS Release 2401. All WHEA 17 spam gone.
So as predicted was purely 2201 BIOS' fault. Just flashed it without changing anything and all is fixed instantly...

97357

Waaaaaay late imho since we reported this over a year ago, but I guess we have to be happy with it.

hi I have the same problem. My motherboard is an asus z 590 ROG maximus xIII hero. When playing a game, the image starts to freeze, so I started looking for the problem, and I found this. My bios is the latest, which I find on the official asus page. BIOS 1701 for my CPU i9 11900k. GPU 3090 rtx. Maybe you have an idea how to fix it.Screenshot 2023-03-25 105514.png