Showing results for 
Search instead for 
Did you mean: 

ASUS Hyper M.2 x16 Gen 4 Card issue with Zenith II Extreme

Level 9

Hi folks,

I have a Zenith II Extreme TRX40 motherboard (non alpha) and am trying to put a 3rd NVME SSD into my ASUS Hyper M.2 x16 Gen 4 Card. The system boots ok with 2 SSD's in the card, but as soon as I put the 3rd one in I get the system hanging at boot saying "Please press DEL or F2 to enter UEFI BIOS setting", with no response from the keyboard...I can't get to the BIOS.

I can confirm that I already have the Advanced\Onboard Devices Configuration setting in the BIOS for the Hyper card slot ("PCIEX16_3 Bandwidth") set at "PCIe RAID Mode". The NVME SSD's themselves are in isolation/sepatate mode (not raid 0 etc), but I understand that the 'Raid' BIOS setting allows bifurcation of the Hyper card into four PCIe X4 groups, allowing for 4 SSD's.

What is confusing for me is that the system has operated for well over a year with the 2 NVME SSD's in the Hyper card - if it wasn't operating in the correct bifurcation mode I wouldn't see the 2 SSD's (maybe none), and so, why is it not allowing a 3rd SSD to be added? Is there another BIOS setting I'm missing?

I should add that I've also tried the Hyper card in the primary PCIEX16_1 slot (GPU in PCIEX16_3 slot), ensured correct BIOS PCIe mode, but the problem persists.

In all scenarios, taking out the 3rd SSD allows the PC to boot into windows.

Thanks in advance for any help here.



Level 9

Anyone with any ideas?

Level 9

Is there really no one here with ideas beyond what I've already tried? Is Asus forum dead?

Level 9

Asus: because we care!

Level 7

Hi, I’m just getting started adding M.2 nvme to my rig which sounds similar to yours. I have the ROG Zenith II Extreme (non alpha) TRX40 also but with a 3rd Gen Threadripper in case that makes a difference. My initial issue was with speed or lack thereof with a 2 m.2 raid setup using the AMD RAID option in the bios. I learned by reading a bit closer that the two slots under the chipset cover are… tricky lol with respect to bifurcation but I did work that out. And now I’m going to be installing one of these Hyper m.2 x16 gen 4 PCI cards to eliminate these issues as I need the PCI slot 4 to run at full X8 speed which isn’t possible if using the onboard m.2 (socket3) slots anyway… here is the doc I read in detail before I ordered my hyper x16:

Of note for you is the picture that shows if your processor/board combo only supports 3 m.2, to use only slots 1,2,4… not slots 1,2,3 It seems from the matrix that your zenith ii with any TRX40 (AMD) proc “should” support all 4 m.2 but I thought I would share this and ask if you did at least try to skip slot 3.

Wish me luck as I’m installing mine tonight lol, I only have two m.2 but I’m hoping for a minor miracle here because so far I’ve yet to see the rated speeds of the model nvme I’ve spent top dollar for… These hyper x16 promise max throughput far over what the mb (including the dimm.2 riser) seem to support

Level 7

i'm not a pc tech, but if i understand your problem properly it seem pcie slots are not compatible to do 4x/4x/4x/4x on your 16x slots
mobo specs:4 x PCIe 4.0 (x16, x16/x16, x16/x8/x16, x16/x8/x16/x8)
You may want to check your BIOS and set the pcie slots to 4x/4x/4x/4x or contact asus about this, otherwise you may find some cards with dedicated bifurcation from the card that might help solve your problem.

hope this help and good luck!