Showing results for 
Search instead for 
Did you mean: 

z390a Stuck on dram/ no display

Level 7
Hi! I just put together my first build and I get no display to my monitor. The qled on my motherboard is stuck on dram with a constant yellow light. I've tried different ram and tried all possible slot combinations but no dice. I've also checked all my connections and everything is in the correct place and secure. Everything else seems to run fine so I'm thinking it's possibly the motherboard or gpu but I honestly wouldn't know.

My specs are:
CPU: Intel - Core i7-8700K 3.7 GHz 6-Core Processor
CPU Cooler: CoolerMaster Hyper 212 Evo CPU cooler
Motherboard: Asus Prime z390-A
Memory: Corsair - Vengeance LPX 16 GB (2 x 8 GB) DDR4-3000 Memory
Storage: Samsung - 860 Evo 500 GB 2.5" Solid State Drive
Video Card: MSI GeForce RTX 2070 8 GB
Power Supply: EVGA - Corsair - TX-M Series TX550M
Monitor: Asus - VG248QE 24.0" 1920x1080 144 Hz Monitor

Level 7
Try different CPU? Was this with stock clocked or on XMP?

Level 10
Not sure if this helps, but that sounds familiar. Is everything new? Do you have any way to check everything, for example your monitor, with other systems/components? Have you double checked your manual for something you may have missed? Are you getting beeps from the motherboard speaker? Are the fans running? Are you sure your ram sticks are seated properly? Are they compatible? I have had problems when stuff was not seated properly... Good luck!

Have you seen this video?

Level 16
To exclude an issue with the graphics card, you could connect the monitor to the built-in VGA...

But, if it hangs at the RAM, the above thing wouldn't do too much... Have you tried to reseat the CPU?*