Showing results for 
Search instead for 
Did you mean: 

Z370G + Gskill F4-3466C16D-32GTZR + POST Issues.

Level 10
As per my topic. I'm having constant issues posting with my GSKILL RAM with the Z370G on Bios BIOS 0430

Gskill F4-3466C16D-32GTZR

I was intermittently able to get it to post and go into windows and when booted it manages to run benchmarks and what not without issues.

Issue occurs with XMP profile setup or when I manually set the timings, increase the DRAM Voltage up to 1.36 -1.37 still no luck the problem now seems to ocurr when both ram sticks are plugged in.

I would get the DRAM Yellow LED on the motherboard with no post and what not, after a few power cycles it sometimes manages to post to boot into the bios safemode.

I've tried loading factory defaults and or resetting the CMOS but still no luck...

I was getting impatient so took one stick of ram out and so far it seems to be able to POST & Boot just fine with one stick.
Tried both sticks of RAM independently to both B2 & A2 dimm slots and works fine.

Anyhelp would be much-appreciated thanks!

Level 13
Morph: Z370 Strix G test build to patch DDR4-3466. Please try it and report back.

Level 7
I just had this same issue this weekend. I rolled the memory modules between my dimms, and everything works great now including xmp. weird. Maybe they just needed to be reseated.