Showing results for 
Search instead for 
Did you mean: 

What happened to bios v. 2004?

Level 7
What happened to bios v. 2004?

Hi there,

I'm stuck on updating my Asus Maximus X Hero bios to the latest version - 2102. I've not had any luck with the built-in Easy Flash tool, or the USB flashback function. If I attempt to use the Easy Flash, I get a message stating I already have the most current bios (not accurate). If I use flashback, an error message informs me that the selected file is "not a proper bios!". USB is formatted correctly in FAT32 and named M10H.CAP appropriately. It's in the root of the drive.

At some point in the past, I downloaded and upgrade to Bios 2004. This version has since been removed from the ASUS website, and I'm wondering if there were issues with it that could've caused me to become stuck. The most recent bios on the official Asus site is 2003 -- 2004 seems to be gone entirely.

What can I try to update my BIOS? Can I go backwards to 2003, and then attempt to move to 2102? Any clues or pointers greatly appreciated - thank you!!

HWinfo report 2004 bios:
Asus official support site as of 13 Oct 2019:

Level 9
Hey man. Yes you can downgrade your BIOS. It should work EZ flash utility ,but i recommend use bios flashback if your board supports it.

thank you for the advice! I attempted to use EZ Flash and USB Flashback to move from 2004 -> 2003, and I was unsuccessful. I'm still stuck on 2004 - any ideas?

well. it has never happened to me. Found this video try this
Weird that Bios Flashback doesn't work for you. If you try update from EZ utility, some bios have protection that you cant downgrade it. But biosflashback should be able to go thru
maybe is possible that bios 2004 was beta and had some bugs and only solution to downgrade it or upgrade is use some third-party tool. well in this situations i'm glad i have board with dual-bios

starting to wish I had dual bios as well 😕
thank you for linking the video, unfortunately I wasn't able to accomplish what the creator of the video was. After resetting my bios to defaults, i'm still unable to read the m10h.cap file from my usb drive. I tried the following things

1) disabled secure boot
2) allowed usb to boot in both UEFI and Legacy
3) Reformatted USB to FAT32
4) Tried another flash drive.

I'm still stuck with "selected file is not a proper bios!" or no error message at all. When I try flashback, the blue light stays illuminated, signalling an issue with the flash. Any other ideas?


I'm happy to report I was able to flash my BIOS successfully using the bootable DOS. Thank you so much for the help!

That is great news. lesson learned. Next time wait week or two if new bios is released. 🙂