Showing results for 
Search instead for 
Did you mean: 

Very Slow Boot

Level 7
Have a Hero X with a Samsung 960 M.2, i7 8700k , 32 gig ram , 2 x SSD drives and a Mechanical hard drive. But it takes about a minute to get to my login screen. Just set a Asrock K6 as my 2nd PC and it takes about 10 seconds to boot.

It takes a while before the Asus ROG screen appears and then a while until the booting into win10 screen appears. Besides this my PC works pretty good but it should be quicker then this. Tried changing some settings and ended up with it just booting into the BIOS before I gave up and hit F5 to reset.

Now I have the Corsair Lighting Pro and fans and LINK but surely these only affect Windows when it starts.

At the moment am thinking about putting my 1080ti in my other machine along with the M.2 960 1TB . Actually the only thing stopping me is the fan noise using the Corsair fan controller in the 780 case.

I do have a few USB devices connected like Fanatech pedals and wheels .

Any clues as to what settings to get a fast boot and I do have fast boot enabled

Level 12
Find the bios setting for the legacy drive settings, it's not under the Boot tab for some reason. Set boot drive which should be at the top of the list to UEFI instead of the default 'legacy' setting. This will prevent Windows from parsing non UEFI drives on boot up. I was up excrement creek without a paddle unless this setting was set to UEFI.

unsure what you mean, boot order is set for the UEFI at first.
The thing is, on the first few weeks it booted OK but every now and then the boot time degrades..

Level 7
ok, an update

Have flashed the BIOS to the latest and with just the M.2 drive attached it takes 27.3 seconds from hitting the button to the Windows logon screen wallpaper. But on a Asrock motherboard ( z370 K6 ) it takes 13.1 seconds. Both motherboards have Samsung M.2 drives, the K6 has the 8600K and the older Samsung 950 and the Hero X has the newer Samsung 960 along with 8700k

After changing the BOOT settings in BIOS to UEFI only ( under CSM ) reinstalled win10 and that made the M.2 drive a GPT partition ( it was MBR ) . But basically that made no difference to boot times.

Like I said the main delay is when you hit the power button..........the K6 can boot up in the same time as the Hero takes to get to the ROG splash screen.

Level 12
Well the CSM settings seemed to make a difference at first but after a couple boots it's back to not wanting to shut down or boot up with any storage drives plugged into SATA ports. Harddrive light will stay on and little spinnie thing just spins and won't boot up. This is with the ROG Strix Z370. At first try it will boot with drives connected but after that it won't shut down or boot up unless I disconnect them. Bizarre to have a board that you can't even connect storage drives to. I wonder if there is anything specific to this in a bios update?

Update: I installed the Intel rapid storage software from the Asus support page for my board. Shut down the system, plugged in all HDD's, booted right up no issues. I didn't enable Intel rapid storage software in bios but something changed after installing it. One of the older HDD's didn't show up anymore but my old SSD and another 250GB drive did show up. Assuming this old HDD was the issue, somehow installing the Intel rapid storage software figured out the drive was bad or just outdated, or maybe it allowed Windows to spot the bad drive disabling it in the process. No more issues with shutting down or booting up since then. Fast boot enabled etc. all working fine now after testing it multiple times.


I have quite the same issue and i would need help

I've installed an NVME SSD on my rig recently (Samsung P961 , which is actually 960Evo in OEM )

It's installed on M2-1, i've put everything on PCIE x 4
I've made a fresh install of windows on it and the NVME is GPT

Though i found it long to boot but i'm actually not sure to be NVME related since it just takes time to load bios

Here's a video to show you what is happening :

I've updated to the last bios, tried to disable secure boot but nothing works

thanks for your help !