Showing results for 
Search instead for 
Did you mean: 

TUF Z390-PLUS GAMING (WI-FI) - Lost Bluetooth after Windows Update

Level 7
***Well nevermind, don't bother reading the post it seems I found the solution in this forum, tried many things from many poster but one of these was to go into the BIOS, turn off WIFI/Bluetooth and reboot into Windows, confirm that WIFI is off (which it was and I also noticed I had no more USB problems). Reboot the computer, go into the BIOS, turn on WIFI/Bluetooth, reboot into Windows and BOOM! Bluetooth is back and working, strange stuff, dark magic stuff (I really don't see why turning the thing on and off in BIOS does anything to Windows) but that thing worked for me at least.***

I've seen pretty much copy/paste same problem on this forum where people had Bluetooth working totally fine and something happens and the icon for bluetooth disappears and after some work trying to remove and install the drivers, in Devices, bluetooth totally disappears and no way to ever get it back or install it back.

Now I had tried many things but this all happened on the 15th of this month when I install 2 updates for WIndows 10 and I did noticed it took a bit longer to reboot in areas where usually updates from Windows will not be able to influence (mainly the part where the BIOS reboots and before Windows starts loading).

Is there a way to manually remove bluetooth drivers? Because no matter what I do, running AsusSetup.exe does nothing (I presume it knows right away that the drivers are installed).

I have tried DRV_BT_Intel_9560_SZ_TSD_W10_64_VER213005_20190801R in my motherboard page and that, like I said, does nothing.

The WIFI itself it working totally fine but I do now have a permanent problem with a USB in Devices: Unknown USB Device (Device Descriptor Request Failed)

Before the update I had no problems at all, now this one is permanent.