Showing results for 
Search instead for 
Did you mean: 

Sudden loss of LAN on 2 mobos same week...??

Level 7
Hi all. I have 2 machines with ASUS mobos. One (older) is a MAXIMUS GENE, the other a MAXIMUS HERO. The machines are dual booted running OSX (one is Mojave, the other Catalina) and Win10. I have an ASUS house router RT N12-D1, with 4 ethernet ports and wifi. The two machines are plugged into router ports (wired Ethernet). Another port supports a NAS drive. Other house machines use the wifi.

OK, so for months all of this is working sweet and easy, totally reliable. Good bandwidth, no errors. Many reboots and power hits (I live rurally and power is kind of hit and miss around here). The older machine has been in continuous service about 2 years, the other one is about 9 months in service. Both working flawlessly. Never any LAN problems until now.

So I go away for about 3 weeks. When I return, of course there's been a power hit. I reboot the machines, and... BOTH the desktop machines report "Ethernet cable unplugged." The NAS drive is fine. The wifi is fine. Check cables, yes plugged in firmly, no rat nibbles. I switch OS, and OSX is just as LAN-less as Win10. I try switching one machine to the unused port on the ASUS router. No dice. I do a long power cycle on the router. No dice. LAN port stays dark.

So now I am really puzzled. Can it be the router? If so, why would these ports fail and not the NAS port? But if it is the mobos, why would 2 ASUS mobos both lose their LAN capability in the same time period, apparently spontaneously? Is this one possible result of an ugly power hit? Is the LAN real estate on these boards kind of fragile? Do I need new mobos? OMG, I hope not.

So I've been frantically googling around, and it seems that one thing recommended to try when your LAN goes dark on these ASUS mobos is to "clear CMOS" and then restore your custom BIOS settings. I have a LOT of custom BIOS settings, so this is a little on the scary side.

After a lot of googling and teeth gritting I learned how to save and restore BIOS settings using a thumbdrive. It's not quite straightforward -- for some reason it trashes my UEFI boot order -- but there are ways to fix that (EasyUEFI under Windows will do it). So finally I got to the moment when I dared to Clear CMOS. Held down the magic button for 10 sec, then restarted and...

OH RATS. Still no Ethernet (even with Win10).

So clearing CMOS, which has worked for some other people, did not work for me. Any other suggestions please, it is bugging the heck out of me that 2 mobos lost their LAN function in the same week, what the heck?