cancel
Showing results for 
Search instead for 
Did you mean: 

Strix Z390-E Wifi issues after BIOS update

Duckysaysquack
Level 7
Hi,

I recently updated to the newest 805 bios for my Strix Z390-E. Everything works fine except for the WIFI. It keeps disconnecting randomly. I
ll be playing Apex and the wifi would disconnect and I can't find it forcing me to disconnect and reconnect. My other devices are all working fine. I can't seem to find any other posts about this. Wondering if anyone else has the same problems.
4,706 Views
5 REPLIES 5

Enderwiggin03
Level 7
Duckysaysquack wrote:
Hi,

I recently updated to the newest 805 bios for my Strix Z390-E. Everything works fine except for the WIFI. It keeps disconnecting randomly. I
ll be playing Apex and the wifi would disconnect and I can't find it forcing me to disconnect and reconnect. My other devices are all working fine. I can't seem to find any other posts about this. Wondering if anyone else has the same problems.


Try an older bios and see if the issue persists.

Enderwiggin03 wrote:
Try an older bios and see if the issue persists.


So I went back to BIOS 602 and I got two random disconnects too. I'm thinking now it's a driver thing.

MrAgapiGC
Level 13
Duckysaysquack wrote:
Hi,

I recently updated to the newest 805 bios for my Strix Z390-E. Everything works fine except for the WIFI. It keeps disconnecting randomly. I
ll be playing Apex and the wifi would disconnect and I can't find it forcing me to disconnect and reconnect. My other devices are all working fine. I can't seem to find any other posts about this. Wondering if anyone else has the same problems.


CHeck on event viewer if DNS issues and let me know. I have the same issues, and I am blaming my ISP. We are using google DNS. but happens on other if i use other DNS.

By any chance did you install the Version 12.0.22.1310 MEUpdateTool.?? I am just asking Aside other issues like audio features crashing etc?
Learn, Play Enjoy! We help and collaborate, NOT complain!

Itzycharles wrote:
CHeck on event viewer if DNS issues and let me know. I have the same issues, and I am blaming my ISP. We are using google DNS. but happens on other if i use other DNS.

By any chance did you install the Version 12.0.22.1310 MEUpdateTool.?? I am just asking Aside other issues like audio features crashing etc?


I did not install any other stuff besides BIOS, I did not install MEUPDATE TOOL. How do I check Event viewer? I'm not familiar with that.

AliAPCMR
Level 9
Can you guys confirm if your pc does a double boot when your pc is unplugged and the replugged back into the mains?