Showing results for 
Search instead for 
Did you mean: 

Strange Keybot start-up behaviour

Level 7
I recently bought a Maximus X Hero and was trying to use the Keybot functionality to start the system by pressing Enter (or DEL to boot directly to BIOS) as my computer case has the power-on button under an annoying little flip-cover, so just pressing something on the keyboard would be more convenient. However, I'm having a few problems with it and was wondering if it's just "how it's supposed to be" or if I'm doing something wrong.

For the record, I have experimented this with two different keyboards, an old Digital Media Keyboard from Microsoft and a very basic HP one, and got the same results, so I'm assuming it's not a problem with the keyboard itself. Anyway, here's the behaviour I've seen:

1 - With no USB devices plugged in except for the keyboard (in the appropriate Keybot II USB slot) and the mouse, I set the ErP ready setting in the BIOS to Enabled(S5), save and exit.

2 - The computer will then boot-up using the keyboard, so Keybot is working, BUT only after I first plug the computer in / turn on the power supply. If I shutdown from the OS, it does go back to S5 state, but Keybot will no longer be able to start it up. Any idea why this would happen, if in theory the computer is in exactly the same S5 state?

3 - At this point I'm free to connect any other USB devices (gamepads, usb hub, etc) and Keybot will still work, per point 2. However...

4 - If at any point I connect (to another USB slot, of course) a second keyboard (namely, a wireless keyboard/mouse I keep next to the TV when I'm gaming from there), start-up by Keybot will no longer work under any circumstances, even if I disconnect the second keyboard. I'd have to go back to point 1 and redo the entire 'set-up' process to get it to work again.

So this is what's happening to me, and I'm a bit curious of the reasons (am I doing something wrong?). It's not a HUGE deal, as booting the computer via Keybot was more a small convenience than a necessity, but I would like to understand what's happening. Can anyone help me with this?


Level 14

KeyBot is primarily supposed to just add programmable macro functionality.
But I do recognize that KeyBot is an added in-line hardware component, running its own little logic, so it is indeed conceivable it creates quirks or bugs or interference with normal keyboard functions.

Some keyboards are not perfectly compatible any more (they use old scan sets), but this is an increasingly rare issue and the chance of you using two such keyboards is slim indeed.

The computer can wakeup from sleep/hibernate with a keypress (or mouseclick) on any USB port. There are BIOS settings to configure these parameters. Many keyboards also include a sleep/wake button (which I despise, personally, but it's still there). So this "added" wake/sleep functionality marketed on KeyBot is basically redundant, if you don't use the KeyBot macro functions then maybe it's better to not use it at all.

Have you compared the wake behaviour with the keyboard plugged into the KeyBot USB port vs other USB ports?
Have you compared the wake behaviour with Legacy (keyboard) USB functions enabled/disabled in BIOS?

Sleep/wake behaviour seems to always be a touchy thing on feature-rich ASUS motherboards. And general Win10 faults/instabilities (over time) certainly don't help simplify things, although you can go through your Windows Power Settings and your USB Power Settings (in Device Manager > Properties > Advanced) to confirm that the USB port/keyboard itself remains powered on when the machine powers down.
"All opinions are not equal. Some are a very great deal more robust, sophisticated and well supported in logic and argument than others." - Douglas Adams


Level 7
Just to clarify, I am not trying to wake up from normal sleep or hibernate (I'd just use any normal key then, as you suggested), but rather from a full system shutdown, which (as I understand it), is what S5 is:

It was my understanding that this is what the keybot start-up functionality was capable off, powering up from a cold-boot. It's possible, I guess, that it's just meant for waking up from hibernation, although the fact that it HAS worked for me (you can't get more cold-boot than having just plugged in the computer to the socket :D) in this state leads me to think it's both capable and supposed to.

Although now I found this thread:
and some people are stating it wasn't working to start from cold boot for them either, so maybe it's some flaw in the chip.

As I said before, it's at most a minor annoyance/inconvenience, but it doesn't stop me from being curious on how it's supposed to work, and why it's behaving the way it does. I am particularly interested in understanding the difference between S5 after I plug the computer to the socket and S5 after I shutdown from the OS, and why it worked in the first one and not on the second.

I'm going to try to explore the USB bio settings, as per your suggestion, and see if it makes any difference. Thank you for the tip.

Level 14
In addition to the fine control over hardware power settings in BIOS you might also have finer controls available (through a software interface) if you use a "smart" PSU which links to the motherboard (like a Corsair AXi or a Seasonic/FSP server PSU, etc).
"All opinions are not equal. Some are a very great deal more robust, sophisticated and well supported in logic and argument than others." - Douglas Adams