Showing results for 
Search instead for 
Did you mean: 

[SOLVED]STRIX z390-E Gaming PCIEX16_1 @x4

Level 7
Today I flashed to newer BIOS, but to be honest I have no idea if the problem was before or not. Anyway I discovered that my 1080 GTX card is working at X4 speed instead of x16 on PCIEX16_1 port.
I have no other PCIE card installed, only two M.2 Disks in mobo slots. No SATA drives.
I tried loading BIOS prefered settings, changing from AUTO to Gen3 at BIOS. Nothing helps. I noticed that many people have this issue as well but their readings are x8 not x4 like in my case.
But apart from that, games run flawlessly (to the limit of GTX 1080 of course) so I'm not struggling with games speed or anything - just found it strange that both AIDA64 and GPU-Z reports small speed mode on this PCIE port.
Any ideas?

Level 7
I found the solution, idea is not mine all the Kudos should go to author of this video
What I did in BIOS was:
I set:
-PCIEX 16_1 slot Link Speed to Gen3
-PCIEX 16_2 slot LInk Speed to Auto
-PCIEX 16_3 slot to x2 Speed (instead of x4)
- Primary graphic card as PCIE
And it works, x16 confirmed at 16_1 !

Moreover from this video,
I learned that even though your card is working at x8 speed, difference between x16 speed is very low - thats why majority of poeple have no idea that their video cards slot is not configured properly.