Showing results for 
Search instead for 
Did you mean: 

Samsung S9 access with USB-C port

Level 7
I am having an odd issue when connecting my Samsung S9 to the 3.1 (type c) port on my Maximus XI Extreme. If I connect the phone no any other port, I am able to browse and access all the files stored on the SD card. If I try this with the 3.1 (type c) port, all appears well until I try to access files in the photos directory. When I access the folder it will read the contents and get a number of them out of order. If I try to open any of the pics, the first one will open, but any attempts at opening another pic brings up an error about the file being too large, damaged or corrupt. I am also unable to copy any of the files from the SD card to a drive on my PC. This does not happen with any other port (3.0 SS).

I have a new, certified type-c cable and it works with the phone connected to a 3.0 port. I have checked the drivers and they are up-to-date. Not sure where to go from here. Samsung is unable to help and points at my end. Has anyone else seen this issue?


Level 7
Well I fixed it by updating BIOS. I hadn't thought about it as I figured it was a driver issue. I hate updating the BIOS as it has never worked in the past. When I got the board it had an old bios. I updated it to 1005, the latest at that time, and it wouldn't boot. Had a NVRAM error. I cleared CMOS and nothing. I did the flashback and it didn't work. I then did the clear CMOS again and it worked. I just updated it and it did the same thing. Takes over 30 minutes to get the process working properly and I'm not sure where the problem is, but messing with CMOS clearing and Flashback eventually works. Good thing I save all my CMOS settings to a USB drive.

Level 7
I have been experiencing a very similar issue with my Z370 Prime-A and a Samsung A320FL (Galaxy A3 2017) phone (it's Type-C but USB 2.0 only). Direct USB-C <-> USB-C (3.1 certified cable) connection is unstable: the phone is either not recognized at all or drops out fast during file transfer (like loading photo previews, etc). The same cable works fine with the same phone and an AMD notebook (where all USB ports are operated by the AMD chipset and not Asmedia).
As long as I remember, the Asmedia USB ports were always somewhat "quirky" on all my ASUS motherboards, even back in the days of Z68 chipsets where Intel offered 2.0 only and Asmedia provided 3.0. I remember using an unofficial firmware updater on that old USB 3.0 chip (and installing the Asmedia driver package instead of Windows's on-box drivers also seemed mandatory).
This time, I still have no solution for the Z370 board (I am on the latest MB firmware and Win10 build). Although I don't have any USB 3.1 Type-C devices yet, so it doesn't truly matter (may be I will change the motherboard before I get a new phone or other "gadget", who knows...).