Showing results for 
Search instead for 
Did you mean: 

ROG Maximus xi Fantom Samsung 970 (1/2 not appearing)

Level 7
Hi all,

I need help as I can only find one of my two NVMe SSD drives on the system.

- ROG Maximus xi formula
- I9-9900k
- 4x16GB G.SKILL Trident Z Neo DDR4-3600 CL18 DIMM
- AMD Radeon HD5800 (I know… waiting for the new Nvidea series to upgrade)
- M.2_1: NVMe Samsung SSD 970 EVO
- M.2_2: NVMe Samsung SSD 970 EVO
- No further HDD/SDD
- Clean Windows10 install with boot on M2_2 SSD
- No BIOS update
- Intel CSME test: This system is not vulnerable, It has already been patched.
- SATA driver
- All drivers have been updated

My problems:
1. M.2_1 appears in BIOS and Device Manager and its controller appears in Storage controller. But it does not appear in Disk Management and Diskpart, so I can’t format or assign a network path. When I review the drive’s Volumes in Properties / Device Properties, it states when I try to populate that the volume information for the disk cannot be found. I spent hours with a Windows technician working on the drivers and also reinstalling W10, but this did not achieve any results.
2. Neither M.2_1 or M.2_2 appear in the Samsung Magician

Thank you for any help and suggestions!

Level 10
start by updating your bios to v1401. I have the same cpu, same board and the same? SSD's (mine are 2TB 970 EVO and 1TB evo plus) they work perfectly in the bios, diskmanagement and samsung magician.

Thanks for your reply ch3vr0n. I just updated to v1401 and it still is not working.

Any other suggestions are welcome.

timvdb wrote:
Thanks for your reply ch3vr0n. I just updated to v1401 and it still is not working.

Any other suggestions are welcome.

I have a brainfart and seek guidance:

Could a MBR format (vs GPT) in combination with CompatibilitySupportModule (Launch CSM in Bios) on "disabled" hide the drive?

Or for that matter a GPT drive that is not prepped?

I always feel as not to get the full scope of that information

i run GPT format and CSM off btw. MBR i did run last year. Same experience.

Level 10
CSM should be disabled unless you're running an older operating system, or want to run something like a linux based live CD. Afaik CSM affects the boot sequence of allowed "software" but it shouldn't prevent a drive from showing up in the OS. Try having it disabled and reinstall the OS.

Level 10

  • If you installed Windows using the media creation tool then you can turn on secure boot.
  • Updating BIOS to the latest should fix allot of issues.
  • Do not use CSM support (As said by someone else here).
  • If you are not using RAID then Install the Samsung NVMe drivers so that Magician can see the drives.
  • Also, an extra bonus: Turn off anything that you don't use like on-board audio if you have a soundcard or Ethernet ports if you only use wireless.

Hi all, thank you for your many suggestions, which I have now all tried. I also converted my SDD from MBR to GPT, but nothing changed my problem:
1. biggest issue: I cannot see my second NVMe SSD on Disk Part and Disk Manager.
2. I cannot see any of my NVMe SDDs on Samsung Magician

Any other suggestions are welcome!

Stay safe and stay home!

Level 11
Sounds like a conflict with Intel IRST.
Try uninstalling Intel Rapid Storage Technology Driver from Programs and Features then reboot your pc.
Next check in device manager if the default Microsoft AHCI driver is installed if not uninstall it from there too.
Now go to Disk management and it should ask you to initialize the drive (if you have not done so already)

Samsung Magician needs your PC to be connected to the internet to show your drives.

Thanks for the tip Kens30.

I uninstalled IRST and the AHCI driver. Tried DM and SM, but no DISK 1 in DM and no DISK 1 or DISK 2 in Samsung Magician. I only see USB disks in SM.

In disk Manager I see Disk 0 which is my Boot and then Disk2-6 which are USB and finally I see CD-ROM.

I turned SATA off and the AHCI driver does not pop up anymore.

However, as soon as I reboot, the CSM mode turns back on!

I also noticed that some drivers are more recent than those listed on Armoury Crate (listed as latest vs current version below):
Intel Chipset: vs
MEI: 1815.12.0.2021 vs 1914.12.0.1256

Level 11
Reading all of the above it sure sounds like a strange problem.
Try removing all your USB drives and load optimized defaults in bios (don't change any settings) leave everything on default.
See how that goes.

BTW do you have another pc so you can test the nvme drive to rule out if it is defective or not.

Post back and i will try to help you as much as i can,