Showing results for 
Search instead for 
Did you mean: 

PCI-E runs at x8 instead of x16

Level 8

I've recently updated BIOS to 0802 and GPU seems to have started running at "native x8 link speed." It used to always run PCI-E 3.0 @ x16, but now BIOS, GPU-Z and CPU-Z all show that it runs PCI-E 3.0 @ x8. Running GPU-Z render test or UNIGINE benchmarks doesn't help. It still shows PCI 3.0 @ x8. Clearing CMOS, reseating vid card didn't help. Running BIOS at optimized defaults didn't help. I'm running out of options here. Do you think I "broke" the mobo or vid card somehow or is it the BIOS issue. I hope it's the latter one. PC is only a month old and I had no issues with it until the recent BIOS update from 0505 to 0802. Here are my specs:

BIOS: 0802
OC'ed? No.
Motherboard: Asus ROG MAXIMUS X HERO (WI-FI AC)
CPU: Intel Core i7-8700K
AIO: Corsair H100i v2
RAM: Corsair Vengeance LPX 32GB (2 x 16GB) DDR4-3200
SSD: Samsung 850 EVO-Series 500GB 2.5"
NVMe (Boot): Samsung 960 PRO 512GB M.2-2280
NVMe (Games): Samsung 960 EVO 1TB M.2-2280
Graphics Card: Asus GeForce GTX 1080 Ti 11GB STRIX GAMING

Thank you for your help!

Stormwind81 wrote:
I put my GPU from slot1 to slot2 of my PCIex16 and now it is showing x16 again.
Dont ask me why but it worked.

Now you should try placing it back in slot 1, and see if it works there now.

I have found, almost without exception, that this issue is a result of poor/incomplete physical contact in the PCIex slots. Using a good-quality contact cleaner on both the GPU insertion tab and in the slot itself, I have nearly always been able to solve the problem [especially when I know that the card worked at x16 previously.]

Look for any warpage on the insertion tab itself, or any dirt/corrosion on the contact areas of the card and the slot. Sometimes it takes a little perseverance, and reseating the card in/out several times. On heavy GPUs, look for sagging of the card after insertion, and if it sags try using a small support to wedge the sagging section of the card up. I have seen this solve the problem, and have concluded that when the card sags, it loses contact in the slot.

I don't claim that this will solve the problem every time, but I've see it on at least 20 different computers and in every case but one I solved the issue this way.

Level 7
[Contact Information]
Name: khalil alghfry
Email Address:
The nearest service site: SAUDI ARABIA
Phone Number: 0545696416

[Product Information]
Product Type: Motherboard
Product Model: PRIME Z370-A
Product S/N: HBM0CS047102
Operation System / Firmware or BIOS version: 3004

[Graphics Card Vendor/model/Chipset/Driver]
3070 rtx \windows 11/ driver nvidia531/ update bios 3004 and 3003

[CPU vendor/processor number]
cpu i7 8700k

[Memory vendor/model/specification]
gskill F4-3200C16D-16GTZR
Trident Z RGB
DDR4-3200 CL16-18-18-38 1.35V
16GB (2x8GB)

m.2 and ssd and hdd

[Problem Description]
Subject: the proplem in bios z370-a prime in slot pcie give me just 1x
I have a problem with my z370-a prime motherboard

The problem is in the bios with the graphics card slot, I have a graphics card 3070 and an i7 8700k processor
Among the experiments is a 1060 gtx card

The important thing is that I have a problem with the number of lanes in the card slot. There are 3 ports on the motherboard, the first one gives 1x
The second gives 8x

How can I make it 16x? I reduce the frequency of the ram to 2133, although my ram supports 3200 and its type is gskill rgb

When I increase the frequency of the ram it returns to 1x

I have reached the problem after a long trouble. It is not easy. Updating the bios is the last and before the last 3003 3004. What is the solution, in your opinion? This is the WhatsApp number if you want 0546124981

Give me a solution
Thank you all for the help. It turned out that the problem was in the processor socket pins. I unscrewed the processor to check the teeth and found two charred and twisted pins. It is good that it works better than nothing. Take them out and bring new teeth from an old motherboard, but the process did not work. It is good that it works at a frequency of 2533 Hz. from nothing

Level 9

had this happen to me once not %100 sure but i think a windows reinstall fixed it, try booting from a usb and see if its fixed. i did also clear the cmos maybe try that first if you havent already