cancel
Showing results for 
Search instead for 
Did you mean: 

New Z390-i Rog Strix, M.2 heatsink screws will not come off!

bhavvv
Level 7
I'm using the same screwdriver that worked for the same screws on my broken Z370-i, and that also worked to install an SSD on the back, but the ones on the front M.2 heatsink are literally sealed / glued down and they won't come off. One of them has already become stripped and the other wouldn't even come off using a rubber band under the screwdriver.

I've contacted the retailer (ebuyer), but apparently this is the first time they've heard of this problem, and they can't do anything until a manage looks at the email I sent with pictures until Monday.

I also recorded a video comparing the screws on both boards, old ones come off easy and fine, new ones won't. It's not a case of 'using the wrong screwdriver size' if I'm using the same one that works on all other m.2 screws!

My Z370i broke due to my fault, I was RMAing my old CPU to Intel, took it off and completely forgot to cover the socket. My dangling AIO heatsink damaged several pins. Now the Z390i can't have it's m.2 heatsink removed!

I bet Ebuyer tell me that I shouldn't be trying to remove it and not do anything cos they're dumb.
971 Views
6 REPLIES 6

bhavvv
Level 7
Here are pictures:

http://imgur.com/a/Nrz0udM

1) New board, top screw stripped, bottom still won't come off no matter what (screwing anti clockwise).

2) Old board, screws come off and go back on easily, done so many times

3) Jewellers screwdriver kit being used

bhavvv
Level 7
I managed to ghetto fix it by putting on the heatisink from my broken Z370i:

https://imgur.com/a/5VeCZAn

So based on reading around on the internet, I tried to put a rubber band under the screwdriver, didnt work. I tried cooking the screws / whole heatsink on the hob, screws still wont come off. I tried using a rubber band on the cooked heatsink. Screws still stuck tight. Both screws are now stripped and useless.

Can I please just get a new heatsink without any pre installed screws Asus? Yes I know this isnt the proper Asus support place, but that is what I will be trying to do.

Ch3vr0n
Level 10
If you know this isn't the proper asus support place, then why not ask it where it IS the proper place. The actual asus support section? https://www.asus.com/us/support/

Ch3vr0n wrote:
If you know this isn't the proper asus support place, then why not ask it where it IS the proper place. The actual asus support section? https://www.asus.com/us/support/


Because when I googles about it loads of threads came up about it here. And it takes a bit more effort to register the board and contact Asus support.

I'm already in contact with the retailer but its a weekend so I can wait until Monday as they are closed. I will contact the Asus support channel then as well.

All I actually need is a replacement heatsink without the screws installed, I dont need to send the whole board back.

bhavvv
Level 7
I still think that this is something that needs posting about so more people and possibly asus themselves become more aware, here is a picture of my now battered and beaten heatsink and I will detail what I have tried to get the screws off:

https://imgur.com/a/A4kvsQy

Initially I only tried the top screw until it stripped and then both more carefully with a rubber band and then left it until I realized to try the heatsink from my old board.

After taking it off and reading around online for advice, I tried heatingup a screwdriver on the hob and holding it to the screws to melt whatever glue it is they used but it didnt help. I then carefully cooked the whole heatsink, warming it up around the screws several times until it was too hot to keep hold off. The bottom screw which was still intact still didnt loosen even with a rubber band used too.

I then noticed that the top screw was slightly raised, and was already in need of some pliers, so I bought a cheap set of 3 from Amazon and the one in the picture was able to decently grasp the top screw, but no amount of turning would still loosen it.

I honestly have no idea how Asus could possibly get these screws on this tight and I will link this thread and information to them and where I purchased it from too.

I am in the same boat with my Asus z390-i mothebroard. I cannot remove these screws at all. This is ridiculous how tight they are, know that the heatsink has to be removed in order to place the m.2 drive. I have got in contact with Asus and awaiting support.

Has anyone found the best solution to remove them?