Showing results for 
Search instead for 
Did you mean: 

Maximus XII Formula Z490 + Samsung NVMe M.2 (Urgent help needed!)

Level 7

Pardon the location, but it is up for general discussion.

I will reward YOU if you can assist me with my issue.

Purchased a new Pc rig.
- ASUS ROG Maximus XII Formula Z490
- 2x Samsung 970 EVO NVMe M.2 Internal SSD

Standard CPU cooler from NZXT, a pretty good GPU, decent amount of ram. Got my machine up and running!

Goal Get both of my NVMe M.2's working as independent partitions. Windows won't recognize my secondary one! Is it faulty?

1. Installed 1x NVMe M.2 in slot M2_1. No issues, installed windows.

2. Installed necessary ALL necessary drivers, completed a BIO updated and installed some Intel Rapid Storage Technology.

3. Pc working! Running! Installed another NVMe M.2 in slot M2_2.

Let's try a trick that is weird..

4. Boot, and check Device Manager seems to be reading both M.2's

5. Check Disk Management, no secondary drive for me to format.. weird?

6. Boot into Windows Installation, can't seem to format the drive there.. weird?

Check back my BIOS, Intel Rapid Storage is enabled. Running both drives in what I believe is Raid.

I don't want that, I disabled Intel RST. Double check within the BIOS, both M.2's appear under "Storage Information"

7. Boot back into Windows, can't detect the storage in Disk Management

Again, only see it when I check Device Manager, clearly it's installed and put in together.

**I have tried swapping their positions, booting them individually. Nothing.
**I have tried Enabled and Disabling CSM. Nothing.
**I have tried putting said M.2 inside my other PC, same issue, BIOS can recognize that's it's plugged in, but Windows doesn't.

I have one Sata being used for my CPU cooler pump, that's all.

Please! Help. Me. $50 Reward deliver in whatever method your heart desires.

Level 12
Learn, Play Enjoy!

Level 7
Have you installed the Native Samsung NVMe M.2 drivers instead of the Windows Drivers? Usually solves all those issues including temperature of the drivers.

Scroll down to Drivers

Hope that helps.