Showing results for 
Search instead for 
Did you mean: 

Maximus X Hero Ethernet dropping connection

Level 7
Hi guys, in the past couple of months, my on-board ethernet has been dropping the connection to my switch/router, which I've verified by pinging, as well as observing that the ethernet light on my switch port turns off during periods of downtime. I've even gone as far as to purchase a new switch to verify that it is my PC's problem and not the switch's.

I've tried installing the latest official drivers from the ASUS website, as well as Mokichu's provided drivers for the ethernet adapter but it isn't helping. I saw that a previous post asked the OP to clear CMOS and restore settings, and I did try that, which helped for maybe a day before the problem started again. Is my ethernet adapter crapping out?

I've already placed an order in the meantime for a USB Ethernet adapter but that's not an ideal solution. Really hope someone can help me out.

Level 7
I've now tried resetting my CMOS again, as well as removing my overclock and I'm still getting the problem. Would sincerely appreciate any advice.

Level 7
This is going to sound weird but is your ram overclocked / in XMP?